HMS hub will not connect to wifi

I am attempting to set up my HMS hardware and cannot get the hub to connect. I get to the point where my iPhone pairs via bluetooth and then goes to a screen to select my network. Only once in my many attempts did my network actually show on the list. I select “other” and my network is automatically entered and I just have to input my password. It then goes to the “connecting” screen and connects to the Wyze Cloud. After that, it sits at “Adding Device” and eventually shows the connection failed. I have activated my service, tried connecting on both my iPhone and iPad, and made sure the Wyze app is up to date on both devices. I have power cycled my phone, router and the hub. I have moved the hub next to the router thinking it couldn’t detect my network but during setup, the app shows multiple networks further away from the hub than my router is. I have not tried setting it up by connecting directly to the router since that is not how I will be using it. Any ideas and/or suggestions?

Are sure the wifi is 2.4ghz? Have you tried connecting via an Ethernet cable directly to the router?

You may need to disable the 5Ghz WiFi and the mobile data connection.

Positive it’s my 2.4 ghz network. I did connect it directly to the router via ethernet and the hub was added as expected. I thought there may be a problem with my account but since I can add it when wired, that is ruled out. While it was connected, I did a firmware upgrade hoping it would resolve the issue but that was not the case.


Disabling the 5Ghz seems to have done the trick. Once I did that, my hub connected as expected. Thanks for the suggestion!

1 Like