Getting video data... livestreaming issues when on magnetic mount

Hi Wyze community,
I’m having trouble with one of my outdoor cams where it fails to reconnect to livestream view, the app gets stuck on Getting Video Data…(3/3), Try to connect: 1 times, 2 times… Please try: 1. Exit app and retry, 2. Power cycle the camera 3. Reboot the router.

About a month ago I got the outdoor starter bundle, got everything setup and has been working flawlessly.
Just a few days ago received my second outdoor camera (the problem camera) and it has been giving me connection issues. It pairs easily, livestreaming works fine indoors (a bit laggy especially when charging), and then place it on its magnetic mount outside about 25 feet away from base station… still livestreaming perfectly fine at about 100-150KB/s. Problem is when I leave the Wyze app (tested on both Android/iOS) or just back out to view another cam it loses the connection to the camera - it will NEVER reconnect the livestream, settings fail to update, and motion events don’t appear in the app.
The moment that I remove the cam from the magnet it reconnects!

Now it might be easy to say “well duh…just move the base station closer, it has a weak connection” but the camera has 2 signal bars in this spot. My original outdoor cam in this same exact position has no issues whatsoever, it connects/reconnects to livestream without a hiccup, with perfect streaming/recording quality.
For troubleshooting I’ve rebooted the router (not the issue, good cam always works), rebooted the base station, deleted the problem cam from the Wyze app multiple times, reinstalled the app on my phones, disabled all recording/detection/night vision/automation features to focus solely on the livestreaming issue.

Any other troubleshooting ideas?
Anyone else noticing similar issues related to the magnetic mount?



I am actually having the same issue. Just got mine yesterday with three additional cameras. Everything worked flawlessly and after about 10 hours one cam will not connect for outdoor live view. The only difference is it does connect and record motion. All the other three work fine. I have tried everything and nothing is correcting the issue. Currently waiting on Wyze support response.

I just received my 3 additional camera bundle yesterday. I am having the same issue. The first camera live streams fine and connects to change setting when I access it from the app. The three new cameras only live stream when they detect motion or if I power cycle them. If I let the sit I can never reconnect to them.
Extremely frustrated at this point.

Tagging on with the exact same issue. Starter bundle cam works great. New outdoor cam pairs fine, but will not show live stream. Not a connection strength issue, I put it in the spot my original has been in and still nothing.

Same issue here, but mine is a new starter bundle. Works as it should on detection but fails asleep and does not wakeup for live view. Done all the above to troubleshoot and nothing fixes this bug.

All other functions work well, just not live view.

Firmware update appears to have resolved my livestreaming issue

1 Like

I’ve had a similar issue with my 1st outdoor camera. It worked great for the first couple of months and then I couldn’t get connected in Live mode. I’d get the same messages you mentioned and would reboot everything to no avail. It would connect maybe every 25-50 tries. The odd part was the motion detection worked great and transmitted the 12 second video with no problem. I got a second one just a couple of days ago thinking it was a camera issue and the same thing happened. I never heard of the magnet correlation and will check that out tomorrow. I’m wondering if the base station could be the issue?

I’m experiencing the same issue with my outdoor cam. It worked great until about 2-3 weeks ago and I can’t help but wonder if it’s a firmware update issue. Current firmware is and as I write this is the latest available. Has anyone heard from Wyze on this?


1 Like

After many hours of working on this problem, over a 2 week period, rebooting etc etc. it turned out it was my cable system. About 10 years ago the cable company added a booster where the lines in my home get split to the different rooms. It turns out that the outdoor cabling has been improved over the past couple of years and the booster was now causing all my issues. My TV’s, modem, and my outdoor camera were all fixed once the booster was disconnected.

Same issue with an outdoor cam Starter bundle . Latest firmware . Can’t get a live stream. It get stuck on stage 3 “ Getting Video Data ”, Will just sit at that screen and eventually time and say connection failed after 10 attempts or just eventually time out. Camera is actually inside and uses magnet base. It detects and records motion.
My other 2 regular indoor cameras that do not use Base are streaming fine.

See if you have a booster on your cable network, could be the problem.

I’m having the same issue with two outdoor cams. Has anyone found a solution?

They work sporadically but are often stuck on step 3 before timing out.

Unfortunately not. After firmware update a few month ago it can pass step 3 and get a live stream half of the time,
Its an improvement , but still not consistently.
Have not done the latest firmware upgrade that popped up a couple of days ago.

I actually wasn’t having issues until I recently updated the new firmware a few days ago. Issues are consistent now with live feeds not loading and also detection/motion Notifications not working.

I reached out to tech support on the issue and got some canned reply that was on battery life. Obviously they didn’t read my text and just cut and pasted an irrelevant topic. It is an unfortunate experience for sure. Buggy solution and no tech support.

Have you checked whether you have a booster installed on your cable company lines? Removing that fixed my problems.


no booster.

I finally got this straightened out after the firmware version progressed to on the outdoor cam and on the base station which added the ability to unplug the base station LAN cable from the router and connect it via wifi. Once those firmware versions were installed I unplugged the base from the router and moved it closer to the cam and things started working again.

That being said, I’m convinced it was the cam and/or the base station firmware that caused my problems because everything worked fine prior to those updates. I currently have the latest firmware on both as of this posting ( on cam/ on base) and they’re working fine.

Don’t know if this info will help at all, but it’s at least an example of what worked in my case. Good luck!

Base station and cam all latest firmware, still waiting tech support to answer my ticket… it seems a known issue , wyze never care about.

My issue, live streaming never works when connect to cellular or different wifi always shows ‘getting video data’ and keep retry… but record works fine.

I have the same issue for a year. Junk.