Garage door controller has Google issues since latest firmware update

After the latest release of firmware the iPhone app no longer shows the open/closed status of the garage door controller. Also, when you ask the Google Home Assistant the status of the door or to open/close it, it announces “that mode is not available” . In the Google Home Assistant app the device does appear as a garage door however it appears offline. Renaming the device in the Wyze app does sync that rename in the Home Assistant App so the two accounts are talking.

1 Like

We’ve seen a similar thing like this before regarding the GDC. I encourage you to log out of the app, and log back in. Please, don’t just close the app on your phone, don’t just restart the phone so the app is closed. Log out of the app. (Doesn’t hurt or help, but no harm in restarting your phone). Then log back in. Let us know if this fixed it, please.

I logged out of the Wyze app and back in, no change. I also removed the Wyze/Google link then re-added it. No change.

There’s been a lot of views but only one reply. Does anyone else have any ideas? All help is appreciated!

Sorry that didn’t help. Well, at least you didn’t need to spend any money, right? We’ll keep looking/watching for a fix for ya.

I spent $40 LoL. No but really. Someone from another issue told me how to install the beta firmware and that did the trick on the GD issue. So problem solved.

1 Like

Wouldn’t you know it that I just bought one and spent hours on it over the last couple days to get it to talk to Alexa properly. Wyze shows door shut with red square around QR. Ask Alexa, checking, hang on… I don’t know about the CG. If door is closed, Alexa will open it if you ask to close and any combination so it basically does not know the status of the door. My big issue is other than safety is security, if I come into the house thinking that I left the door open (say my wife closed it) I would ask Alexa to close the GD and it would open it. How do I get the beta code? Oh, while I am here, any idea how to get Alexa to announce that the door has been open too long? The notifications on the phone isn’t doing it.

Sorry for the super late response. I lost track of time. Not sure if you have this resolved but for someone else looking. I plagiarized some instructions from another user.

Start the Wyze App then…

  • Go to Account
  • Go to About
  • Go to Beta Program
  • Select Edit - Top Right
  • Scroll down through the list and toggle / Check the GD option
  • Select Save at the bottom

This will enable the Beta Firmware for the GD. You can also select other devices if you are so inclined.

Then go to Firmware Update page in Account and see if an update is available. You can also go to the GD on the Home Screen, Select Settings icon, top right, and scroll down to Device Info. From there you would select Firmware and see if there is an update for you. Note: you may be prompted for the update when you start the GD camera. Also, once your done with the update I recommend going through the same process and unchecking the device from the beta program or you will get constant notifications of a new beta update as they release them (somewhat frequently).

The GD notifications are set separately from the camera. To change them, open the Wyze app then click into the camera that has the GD adapter, Then Settings, Then Accessories. Then GD controller, Then Notifications. Enable what you wish.

This problem is back with firmware I’m tired of hearing, “Sorry, that mode is unavailable with (device nickname).” I’ve done all of the above at least twice. It isn’t the Google assistant because it works fine with the other garage door opener on the same network. I’ll try deleting this opener and reinstalling next (tried and failed), but a robust solution would certainly be welcome.

I have the same issue with Google Home and the same GD firmware version. Oddly enough Google Home begins to see it as online if i go into the Wyze app and open/close the GD from there. But at some point it desyncs and I cant control it from GH or Google Assistant again.

The first time I read your post, I thought GD was “gawd damn” instead of Garage Door LOL

I just purchased the GD and installed it a few days agao and set it up with Google Assistant and it was working great. Performed the update yesterday to and now Im having the problem with is saying Sorry, that mode is unavailable for Garage Cam.” Hope they fix this soon!! Its easier to just top the Shortcut I made for it on the lock screen of the iPhone or say Hey google, open garage door when Im riding on the motorcycle. Not very easy to open the Wyze app, tap on the garage door, wait a few seconds for it to connect, and then tap to open it from the Wyze app when on pulling in on the motorcycle.

Try resetting the controller QR code through the Wyze app. It went offline on me again about 4 months ago that this was the only way I could resolve it.

How did you create a shortcut on your iPhone to open/close the GD?

Well it doesnt work now since the upgrade but what I did was first setup a PIN in the Garage door Cam

You need to go to Assistant and put in the commands:“open garage door"then a new command”"

Then go to shortcuts app, add new shortcut, type in assistant, and it will show your most recent assistant asks (that why you have to do that step first). Put a “wait” in between, 2-4 seconds, depending on your network and phone and luck. You’ll have to play around with the time, mine ended up being 6 seconds. See screen shot below for reference.

Then I was able to put that shortcut as a widget on my lock screen so I dont even have to unlock the phone. That one shortcut will open and close the garage door for me. But again, hasnt worked since the upgrade.