Friendsgiving Redemption Code Not Working

I tried to use my “Friendsgiving code” today (I had one for $30 off) to purchase the vacuum, but it wouldn’t work.

I was signed in to my Wyze Account. I tried entering the code in multiple locations but it failed everywhere. I didn’t try any other code (so it wasn’t a stacking issue), I tried typing it out, I tried copy and pasting it, everything. It was definitely the right code, it just wouldn’t work.

It says it is supposed to be valid until March 31st:

Anyone else have problems with this? I have no clue why it is not working. I haven’t redeemed it yet, and nobody else has ever had access to the code, not even my wife. I wonder if it is incompatible with using Amazon Pay instead of directly through a credit card? Did anyone else get theirs to work through Amazon Pay?

I went through with the order without the code this time, but I would really like to be able to use it.

Yes, I’ll probably contact support soonish, though I’m not sure they can do anything about it. They’ll just assume I’m typing it wrong, not signed in, or used it already, none of which are true, and on other codes they’ve told people they have no access to do anything about redemption codes…so I am concerned why this isn’t working when it’s doubtful support can do anything (as they’ve told others before).

I haven’t had this issue.
Could you try a different web browser and/or device?
Still contact support if needed and explain what you have tried. Many times support will assume user error because it’s a frequent occurrence.
(206) 339-9646 Available Monday - Friday 5 am - 6 pm PT and Saturday 8 am - 4 pm PT


That’s a great idea Brady! Next time I make an order I will try it from a different device &/or browser (maybe clear my cache and such just to be sure), and then if that doesn’t work, I will contact support. I’m glad to hear that it worked for someone else, and wanted to check if others got theirs to work okay (glad it did, thanks for the response). It just seemed so weird that it didn’t work for me. I’m hoping it was just some temporary bug.

I’m sure Wyze will launch another product within the next couple of months worth spending it on, otherwise by mid-march, I’ll just buy one of the others I don’t have yet…so not a huge rush, but certainly would like to be able to use it!