First camera, turning into a bust. error code 90

Setup was going well, got to the point that it tried updating the firmware, says it completed and then hitting finish setup, says it’s not connected, my router says it’s connected, I’m able to go into the Android app and reboot the camera, but it still says not connected.

Left it unplugged for a while, no change.
Rebooted router, phone, then camera, no change.
Deleted device from app and reset it up, hit finish setup, and goes offline.
Also pulled SD card and redid everything again, no change.
Checked wireless interference, my 2.4Ghz is at -40, next closest is -80.

Wyze Cam V2 firmware
Google OnHub(TP-Link)
Google Pixel 3 XL

in searching i’ve found that i can manually flash the firmware, and that i’m still 2 firmwares behind, trying to download from the site is getting me “404 Not Found”, does anyone have the file that i can download?

I’m at a loss, any help is appreciated. Thanks.

Hi @Zero welcome to the community!!!

try this link to get the most recent firmware:

thanks for the reply, that is where i go, but clicking on one of the firmwares still results in 404 Not Found.

Yep, sure enough, i just tired getting to a bunch of the different versions and all the links are broken - @WyzeGwendolyn do we need to open a support ticket for this, or can we notify the correct group through here?

1 Like

thanks for the help.

1 Like

just opened a support ticket # 336974
just to make sure we are covering all the bases :slightly_smiling_face:

for future reference if you need to submit a support ticket:


thanks again, if updating the firmware doesn’t work, that’s my next stop.

Sorry about that, folks! You should be able to download the firmware now.

@Zero, if you still have trouble, please send in a support ticket.

@steve4335, you did a great job and I appreciate your help! :slight_smile:


Thanks, I will try it tomorrow, do I need to step up firmwares, or just jump to the lastest?

that has done it, thanks, firmware is not longer a link, so i downloaded, completed setup and it downloaded and installed, seems to be working now. thanks.


Wonderful! Thank you for the confirmation, Zero. We usually don’t post the current firmware since the devices should upgrade to them in the usual way (though sometimes something goes funky and interferes). As you found, using an older firmware should allow people to upgrade to the new one.

I’m happy that worked for you! :smiley: