Wyzecam v2 unable to connect to wifi after latest firmware upgrade

My wyzecam v2 was working fine until the app indicated that a new firmware was available. I didn’t see any error while the upgrade was running, but after it finished and the camera rebooted, it wasn’t unable to connect to my wifi network.

I tried to solve the problem pressing the setup button under the camera to reset it, but this hasn’t worked and I tried several times. I uninstall the camera from the wall and I put it near to the wifi router, but the problem didn’t solved. I reboot my wifi router several times and it didn’t work either,

When I tried to connect to the network using the app wizard, in the last step after it reads the QR code, I checked my router and I see a device with the same mac address of my wyzecam v2 (it’s printed on the camera label), so I think it connects to the wifi, but something isn’t working in the camera.

I also have a wyzecam v3 and it keeps working fine, so isn’t a problem with my wifi network,

I ran out of ideas other than the new firmware is the problem and I need to know how to back to the previous firmware.

Any ideas?

David L.

Here are the instructions for flashing the firmware. The release notes page that’s referenced will have firmware you can download

1 Like

Thanks Victor, I was able to downgrade the firmware and now my wyzecam v2 is working!

Note for wyze developers, your latest firmware created this problem and I lost a lot of time, even I could miss some important event while the camera wasn’t working. I don’t think it was just me, googling a solution I found other people indicating the same problem.

David L.