Finally solved the socket-staying-on problem?

Folks may remember that I’ve had an ongoing problem where the front-door lamp socket supplying power to my cam-v3 was being controlled properly, but the one on the other side of the door was staying turned on. Attempts to install the latest firmware didn’t solve things. I’d stopped wrestling with it, having other things to deal with, but it’s been misbehaving for well over a year.

Finally I hit upon the idea of swapping the two sockets, so the problem child was the one powering and connected directly to the camera, then trying another firmware update. That seems to have solved it.

Best guess I’ve got is that when the camera updates the socket firmware, that update was not being transmitted to other sockets associated with that one. Not a completely shocking design error, if so, but an annoying one.

I’m hoping that this update included a patch which will ensure that all the sockets are kept at the same firmware level. If not, well, at least it’s working for now and I know what to try if it misbehaves again.