Error Code -90

One of my Wyze Cam Pan models has started showing an Error Code -90 message.

I just looked for the camera on my network. My WiFi router shows that it is connected. My WiFi router even shows that it has download traffic (occasionally, there is a small amount of data sent to the camera). I have not seen any upload traffic (traffic that could be related to showing video to a user).

In the app, I can select Update Firmware from the Device Details page, but it never moves from 0%.

I have this camera set up on a property 1,000 miles away. My handyman unplugged the camera for 15 seconds and powered it back up. He did this twice just in case the first wasn’t done properly. That did not fix this issue.

Any suggestions? I got tired of looking through all the Error Code 90 forum messages. I never found one that matched my issue exactly. This camera was working fine for well over 6 months. The other v2 cameras on the property are still working fine.

1 Like

Have you tried a Restart Device from the “Device Info” page?

1 Like

Yes. That did not change anything. The device is still visible on WiFi throughout the “restart” attempt.

There are several things network wise that could be causing this issue, and everyone’s set-up is different.

Here’s the connectivity troubleshooting guide:

If that doesn’t solve it, keep in mind that this is primarily a user-to-user forum. If you don’t get help here from the community, file a support request including log files. That will ensure that the logs are captured. You might want to submit the ticket right away because there’s somewhat of a backlog. You can always let them know it’s already resolved when they contact you.

1 Like

If power cycling doesn’t work for you, you might have to setup the camera all over again with the setup button on the bottom.

Just experienced this on one of my V2s. In fact I was sitting in the same room with it and noticed the IR relay just started clicking all on its own. Thats when the cam went offline. Its been over 2 hours and still can’t get it back online.

All same symptoms as the OP here where

  1. my WiFi management tool shows the device is online and has an active IP.
  2. The LED on back of the camera randomly cycles through blue and yellow.
  3. Hard reset the camera does not help.
  4. It is running beta firmware .40, but as this post implies, this has been happening before beta firmware existed.

Surely there must be some better answer for this than to file a support ticket. I have to believe that this has happened enough times that there is surely a reason for this. The cam just seems to have bricked all on its own. Not good…

1 Like

Removed the MicroSD card that that worked to restore operation. I guess the lesson here is don’t use an SD card if you can avoid it if and until there is a root cause.

Glad you figured it out! :slight_smile:

A -90 error code can be caused by a lot of things, and a wonky SD card is one of them. If you’re curious, here is a list of the most currently documented error codes. It’s supposed to updated with more, but I’m not sure when that is going to happen.

Error codes and their meanings

Appreciate it :point_up: @DreadPirateRush

Yea when I took the SD card out and tried to delete all the files on it from the computer, there was some file in the recording folder that was still reporting as open. I could only resolve that issue by reformatting the card. So I guess for that same reason, the camera couldn’t validate the file system and just froze.

This however is scary since for those who are 100s of miles away from the camera, no amount of restarts would help. This is another opportunity for Wyze to make the camera more reliable.
The camera operation should not stop because of a problem with the SD card. Need to be more bulletproof.

1 Like

There are several threads on the forum talking about recommended SD cards for use in the cameras. Many manufacturers don’t even warrant their regular cards in continuous write applications, but their “high endurance” cards are. I would think one of those would be optimal in a situation where you are not located where the cameras are. :slight_smile:

Point taken, but even then, I’m sure the card manufacturers can’t guarantee no corruption, so its better for the camera to be able to be robust enough to not be affected.

We removed the microSD card and reseated it several times, The first time it read 100 GB out of 119 after formatting. It also failed formatting several times during this process. The second or third time it finally took the card again and started working properly. We replaced it with a spare for the night. It now appears to be working properly with a SanDisk 128GB ultra 633 or 667 I have forgotten which. Either way, it works again. However for someone hundreds or thousands of miles away. I realize this is not much of a solution.

Hope this helps,



I used an SD card purchased from Wyze for use in the camera, so I kinda hoped it would work.

I’ve noticed if there’s a faraday cage between the router and camera this will cause connectivity issues. Metal blinds, Aviary,Squirrel cage,ie- wire box,etc…
I’ve only had these connectivity issues since last firmware update. I suspect it’s the wifi watchdog good connection threshold kind of like your phone has. Its measures wifi signal strength and will disconnect when signal becomes choppy. Maybe some dev’s could elaborate. (Idk what wifi band the camera runs on b/n/g but make sure other devices such as ceiling fans or remote thermostats aren’t causing interference. Also router channel should be set to 10, imo it’s the best channel)

It happened twice after installing a new. It is cheap but going to return; looks annoying