Echo Show "Waiting for Wyze"

Just set up an Echo Show 8 that I got my wife for Christmas. Our Eufy doorbell camera shows up flawlessly. Our four Wyze cams do not. (3x V3 and 1x V2, all with up to date firmware.)
I was really hoping my wife would be able to view the cameras in our newborn and toddler’s bedrooms from the Show while she’s in the kitchen.

At the moment, every time I give it a command to show a Wyze cam, it simply says “Okay” and then shows “Waiting for Wyze” for about 15 seconds and then goes back to the home screen. No errors or any indication as to why it can’t show them.
To make matters more confusing, all of the Wyze cams show up perfectly in the Alex app on my Android. The skill is enabled, linked and working fine. Just not on my brand new Echo Show.

I’ve checked to make sure I’m on the right account, devices are discovered and on the same network. I’ve reset my account credentials, disabled, re-enabled the skill, and relinked the account.
Not sure what else to try at this point. But it’s very frustrating. This was the whole purpose for puchasing this device as a gift. And as mentioned, my Eufy camera doorbell is working flawlessly.

Searching forums and Reddit has produced nothing useful. Does anyone have another suggestion before I give up on this?

1 Like

When I see that, changing the 2.4 wireless channel usually works for me.
If it’s set to auto try changing to manual and select channel 1,6 or 11.

1 Like

Interesting, I hadn’t considered wireless channel issues. I do have my access points running auto channel. I’ll give it a shot. Thanks.

I’ve tried the channels you suggested on the access point my cameras and Show are connecting to, with reboots in between. Still getting the exact same result.
Any other ideas?

Was just throwing a possible network problem out there, because if live view works in the app, it “should” also work with the show.

Earlier in the year the V3 stopped working with Alexa for a few weeks, but that was fixed for me by an Alexa app update More recently I bought a V3 Pro, had trouble with that too for a while until the Alexa app was updated.

Right now, V3 and V3 Pro working fine, in both Alexa app, 2nd gen Show 10 and also Fire stick.

Doing a factory reset and adding it directly to my wife’s account (instead of mine and then switching it to hers; we have a family account) seemed to work.
Now my problem is when one cam is open and I want to display a different one, it comes up minimized. Is that normal?

1 Like