Doorbell Doesn't connect, blue light flashing

So finally my pre-order comes, I installed it according to the instruction. But I cannot set it up successfully with the app.
It scans the bar code and keep flashing blue light, and eventually the App said connection failed. I checked from router’s device list, I see the MAC address listed there, IP address assigned.
I tried to use wifi extender just avoiding signal strength issue, nothing changed.
I measured the voltage is about 14V so I changed to a 24V transformer but nothing changed.
I used the USB port at the back of doorbell, still got connection failed.
I tried to use my phone to tether a AP, and it works, it connected to the server and I can see video from the APP. I used the tethering AP to make firmware update, and change back to my home WIFI, nothing works again.
I did factory reset, connection failed. With tethered AP, works again. But I cannot put my phone near the door all the time.

I’m confused what is the difference between of a Tethered AP and my WIFI router?

Does anybody here see the same issue?

1 Like

Welcome to the Wyze community @kkguokk!
I don’t think power is the issue here.
Make sure your phone is on the same network you’d like to connect the doorbell too and that the network is a 2.4 GHz network. if your 2.4 and 5 GHz networks are combined, try separating them, some Wyze products have issues with the combined network.

I have also seen in some cases that location service is required for the Wyze app. I’m not sure if it’s needed here and why it’s required p, but it’s just a possible solution.

1 Like

Thanks, @Brlepage .
I tried 2.4G and 5G networks. I have a combined AP and also a separated SSID side router. I even tried a 2.4G wifi extender to extend a new SSID, it doesn’t work.

I can see the device MAC from router, I think it’s connected to my WIFI. And also according to WYZE manual, flashing blue means it’s connecting to external network… it is stuck there. I’m also pretty sure I didn’t add any restriction on that address.

I’ve grant location service to WYZE app, and btw, I’m at Wyze beta. Maybe I should turn off beta, but how?
I also tried ios app, same issue happens.

it eventually resolved by changing the DNS setting in my router.
I have a local DNS server in order to cache DNS and speed up, But apparently the doorbell doesn’t work with that. After I set google DNS as the first priority of DNS server, it finished setup without a glitch.