Doorbell designs are terrible and tech support knows less than I do about functionality

I bought the V2 doorbell after first purchasing and returning the pro version because after getting that one I found out that it uses the power from your existing doorbell low voltage ringer but actually disables it!. This V2 unit would “kinda” use your existing ringer but it is the most obscene design I have ever seen. They use the doorbell low voltage transformer to send a signal to the doorbell and then a remote box that receives a wireless signal from the doorbell to initialize a pulse to ring your existing doorbell. All this instead of just using the existing wiring with a good old fashioned “connect the wires button” Ring was at least smart enough to do this. I very much like all of the other WYZE cameras, but their doorbells are barely over 1 star. I gave up on this doorbell and was forced to go to the pro (That I hate the design of) because after 3 tech support calls trying to get the V2 to work again I just gave up. I actually had to inform the tech how to properly set the chime in the app! But it still did not work reliably so I gave up and tossed it in the garbage. Had to because I kept missing deliveries because the bell would ring outside at the device would only ring inside the house randomly. Like every 3rd or 4th time the button was pushed.

3 Likes

Are the wire connections secure and have good contacts? What voltage/VA is your transformer?

My doorbell sometimes crashed and rebooted when I pressed the button. I disconnected and sanded all copper wires contacts until they are shiny. Don’t have the problem ever since. I have a 16V/10VA transformer.

Definitely not the issue. Contacts are all perfectly shiny without the slightest hint of corrosion. Voltage at the doorbell leads is 16.4 volts. Tested while pushing the button to ensure there was no voltage drop using and old school analog meter. Rock steady. I did not have any issues with crashing or rebooting. I first had an issue with just the inside bell not ringing. Then I called tech support and they had me alter wiring at the bell. Bell then worked, though it would now only “ding” as opposed to “ding dong”, however I then lost streaming. Called tech support again. They had me reinstall the camera. Did that and it worked for about 5 minutes or less. Tried to re-install again. No luck. Camera would record but not stream. SO I could look up past history, but not live. So, now I bought the Pro. How lovely that they got rid of the SD card slot “for my security”. So if I want to review or store video events I have to pay them for cloud storage. That was the only reason I got rid of the Ring. Well, BS, I simply added another cheap WYZE camera with an SD card above the door so that I have a doorbell a recording capability but I am not paying Wyze’s ransom.