Do I have a brick now?

Hi, I updated before July 21st, but now one camera cant connect to the network anymore. It wont even let me setup the camera again…all I get is a red light and nothing else. The camera sits maybe 10 feet from the router. My other camera is much further away and still connected. Do I now have a brick? What do I do?

I would suggest trying a manual firmware flash, this usually fixes issues like this.

Does it have a SD card installed in it?
If so remove SD card and see if it then works.
I have had a full and/or corrupted SD card cause troubles like that in the past.

I’ll try that now, thanks

I got to the end and found out it makes it work with the pre-existing connection that was already made. I deleted the camera from the app and tried to re-install it. There is no previous setup for it to work with. What do I do? I wanted cameras that would work as advertised, not cameras that make me jump through hoops just to work!!!

1 Like

I dug up an old V2 and tried to update the firmware. My desktop is a jumble of wires. I pulled the V2’s power by mistake.

I had to flash manually. Question is, why can’t the camera recover gracefully? I understand you can’t cover all cases, but I was only a few seconds into the update. The update file is about 10mb. I figure it hasn’t completed the download, and yet the firmware is already hosed?

The camera will still work. You should be able to flash the firmware, then set it up again like new.

I flashed it and its just showing a red light but the app does not find a camera when I try to add one. So, essentially I have a dummy camera with a light now. I wonder if Wyze’s competitors reward their customers with bricks advertised as security cameras?!?!

You may want to contact Wyze Customer Support about this issue!
By phone: (206) 339-9646
Or online:
Wyze Support has extended their live support hours for a better support experience. ( Excluding Holidays & Emergencies )
Monday - Friday 4 AM – 8 PM PT

1 Like

Is there any tech out there that if you power it off in the middle of a software upgrade, it’ll still work once powered back on? Depends on the process I guess, if it wipes then replaces, or just overwrites, I don’t know. Anything I have says do not power off during off upgrade.

One way is to have a very small code in ROM that takes control on power up when a previous flash isn’t completed. And retries.

Not in the middle of the current flash, but the next flash attempt.

There are probably others.

1 Like

Thanks for the info. Hopefully the engineers/devs have thought about this, future addition maybe if something like this isn’t already in place? Hmm

I assume you mean after pressing the setup button? App won’t find the camera if it doesn’t say ready to connect.


I have two v3 cameras that bricked shorty after successful firmware updates. The second cam was a replacement for the first cam. I am getting another replacement but this time I am not updating. I see a lot of posts about many cams getting bricked with a solid red light on. You can manually install firmware (turns purple) but after that they go back to solid red and can’t be reset. These cams have a usb port. It would be nice if you could just connect them directly to a computer for advanced support, testing and flashing.

I fully agree… I have had 6 cam v3 and 4 of them are now bricked… Huge waste of money and time as Wyze doesn’t cover purchases made in Canada.