Disappointment with continual v2 cam issues: time shifting and connection lost

I have a wyze cam v2 and have been growing increasingly frustrated with the lack of usability of even basic functionality. The ability to scroll back in time on local recording to a specific event is so hampered that it makes the camera basically useless. One issue is that the playback timeline is solid blue, so there is no indication of when an event happened. I understand for local recording that the video is simply laying down video to the SD card, so there should be no expectation of motion detection or whatnot without additional processing. While that may be the case, please provide an option to specify the time I want to jump to.

Currently, to jump back in time, I have to swipe and hold down my finger to the approximate time, and hope I came close. If I am looking to jump back several hours, I have to jump back as far as my physical swipe will allow me on my screen (i.e. thumb all the way to the right of the phone’s screen), then wait for the camera to load the playback, and then continue swiping back in time. Yes, you can jump to a specific day, but is it possible to jump to a specific time??

Even if that were achievable, my camera connection gets “lost” if I try to scrub through the timeline too much. Specifically, in the app, I tap the camera thumbnail, it shows me the live feed. Then, I tap video playback and can scroll in time. If (for example) I jump back to 5:30pm, watch a few seconds, then try to jump back to 4:45, and then once more to 4:15, the bandwidth will drop to 0 kb/s and the camera will go into “connecting mode” and timeout after the requisite three tries. I can’t click back to live, and eventually (several minutes later) I will get live picture, with the timeline still showing the last time I tried to scroll to. I go back into the playback mode and try to get closer to 4:15 and then get stuck loading. Even if I restart the camera, the view local playback option is shaky

My camera’s wifi connection is strong according to my router stats and according to the wyze advanced settings, so I don’t think it’s a connectivity issue.

It could be a unique defect with this camera but this functionality used to work and now it doesn’t. Again, it’s very disappointing that the quality of the software has not improved, and I don’t love that I spend more time troubleshooting than enjoying the product. Perhaps I will try Wyze support for this, but the time I spent RMA’ing my bricked Wyze Pan was enough for me to consider moving away to a different solution.

1 Like

Suggest you try that again with the camera near you. See if it starts clicking and rebooting. Either way, I agree with you, the playback is clunky at best.

1 Like

Completely agreed - local playback seemed to barely work before but now the camera just freezes up whenever I try to view a recording from SD card (Android). I had gotten used to waiting 5-10 seconds for clips to appear on the playback timeline but at least they played. Now the camera “loses connectivity” for an indefinite period of time when I try to watch one. Wyze should really let people know this before they waste extra money on SD cards for each camera.

I found this thread because I’m new to WyzeCam (just bought one last week and got an SD card yesterday) and I’m running into constant reboot / connection lost messages when trying to scrub through my Playback video. I hear the clicking. Weirdly enough, the drop in connection is when I turned lights off last night and I’m curious if the “change” in lens causes this.

I’m not sure what is going on, but if this is how the camera acts when trying to do something this basic, I’m a bit worried for how things will go in the future.

Welcome @MacStainless If you upgrade to the latest FW and are having problems with clicking and “loses connectivity” as stated by @seth.winkelmann.
The solution seems to be downloading the firmware to a uSD card and manually updating.

Thanks @dr.know. I’m in the latest firmware but I could try to re-flash it via the methods you mentioned. Should I use a different SD card then the one in the camera or can I use the same? I’d prefer to not lose my continuous recording history from the last 12 hours. Thanks.

You could use the same card w/oher recording since the boot strap will look for a file called demo.bin and it Should work.
Personally I’d use a blank card with the FAT32 format rather then take a chance bricking the unit. The file is only a little over 10Kb. I used a 2GB card from an old camera and it worked fine.

i also face similar issues, even with latest firmware

If i click on the camera to expand, it often gets stuck.

My Wi-Fi is quite robust, Ubiquiti stuff with gigabit networking. The Access Point is quite near to the cameras as well.

When i wish to expand something to see the garage area, by the time the camera wakes up after getting stuck, the event is over!


Hi Jamal, Besides a bad FW upload, a bad uSD card will cause these issues.

Wondering why SD card would be an issue for watching a live feed? The cameras can also be run without an SD card so I don’t think it is the matter in this case. I also have 2 cameras with Wyze SD cards and 2 with a 3rd party card. All perform in similar fashion.

Sometimes, i also get error code: 13

I’ve had the same problem with a bad FW update. Had to update from a clean format uSD card.

Even though you are not using the uSD for streaming the cam may be attempting to write to a bad cell on the card and stuck (or pausing til’ timeout) on that task. The processor will only do one task at a time.

  • Try removing the uSD from the camera
  • Check the disk with the command line C;\Windows\system32>ChkDsk X: /r Where X is the uSD card
  • Format the uSD card and un-check the default “quick format” option which will force a complete overwrite of the card and fix or lock out bad cells.
  • @tomp has also recommended: Using This Standard Program 2 for formatting.