Connection Issues to Wyze Cam v2

I just got my first camera on Friday and so far things have not gone well.
Currently have a 720p camera setup using it with iSmartViewPro and also with iSpy Connect. Works ok no problems connecting.

Wyze Cam v2 with latest firmware and latest iOS app on iPhone 7 as of Friday June 1st.

The issue is you open the iOS app and it either connects or it doesn’t connect and the application crashes. 25% of the time it works and the rest fails.

I have performed the recommended suggestions online. Factory Reset and did the RouteThis tool. Sent the code to tech support but haven’t heard back yet.

So wondering if anyone has any ideas? You think the camera is just defective?


I tried it with my an Android Tablet and didn’t have problem like on iOS. Just tablet too slow to run the application.

Yesterday re-did my wireless router setup an Asus RT-AC68U because of a new firmware recommends a system restore. Ever since doing this the camera the application is running much better. up to about 80-90% always gets connected.

So feel better its not a hardware issue.

Still waiting on tech support to get back to me. Its been now a week.

I am using the Wyze app on my iPhone. Works just fine on wifi but cannot connect when away from home and not on a wifi network. Is the support to connect just using cellular connection. Any remedy anyone can suggest?

I think mine is defective. It stopped working with the latest software update and I can’t get a connection now. Tried deleting the camera altogether but nothing works. It just spins , pause and spins again over and over.