Connecting Wyze to Eero Pro 6 Mesh Wifi

I leased an Eero Pro 6 Mesh Wifi from Mediacom and spent over 4 hours yesterday trying to get my Wyze network to connect to it. I kept getting “device not found” and “session timeout” errors. I could not get it to connect to the wifi.

Eero uses the same name for both the 5 and 2.4 GHz networks so a lot of posts stated you need to switch the Eero to 2.4 GHz before it would connect. That did not work either.

So, I tried again this morning. I had been using a Wyze Cam V3 and a Wyze Base Station. This time I grabbed a Wyze Cam (V2) and it connected immediately.

The rest of the devices I have including the V3 and Base Station hooked right up.

The Eero Pro 6 is awesome but if you are having problems setting up your Wyze devices I suggest grabbing a Wyze Cam (not a V3) for the initial setup.

1 Like

Had similar issue with my Orbi. Ended up I had not ‘allowed’ to connect to devices on my network. I bet that is your issue too. Hope this helps!

1 Like

If you are using an iPhone, take a look at the Eero setup. Go to settings scroll down to EERO. Check for the Allow Eero to access the network. ? That was my issue with the Orbi app. So just maybe same for you with the Eero app.

1 Like

Hi, I just bought an eero Pro 6 mesh router and I am trying to connect a Wyze Cam Pan V1 (and my other Wyze cams) to it and I keep getting the message of “Cannot find specified network”. I am using the Wyze app for Android and the router is using the 5Ghz band. I have tried setting the router to the 2.4Ghz band but that does not help.

Any assistance will be greatly appreciated.

[Mod Note]: Your topic and associated replies were merged for better visibility and consistency in grouping similar posts. Please avoid crossposting the same question in multiple threads

As you probably know the cameras only use the 2.4ghz band, so that is a major point. The message you are receiving could be caused by any number of issues. Have you tried a different camera? Can you check to be sure the app isn’t adding a space to the end of the SSID or password? There is another post suggesting you need to tell the eero to allow the camera to connect.

Plenty of things to check.

Never mind the other post…I see you’ve already been there. It’s best to not open multiple threads for the same issue.


I recently got an Eero Pro 6 from my internet provider and now NONE of my Wyze products work. My light switches say none found, it can’t find my thermostats and none of my 4 cameras can connect. I spent an hour with customer service and their final suggestion was to ask my internet provider to change the wifi channel. I spent an hour with Eero customer service and they had no idea how else to help, and their suggestion was to contact Wyze. Super frustrating. Does anyone else have any ideas?

Hello @fjrobledo1 and welcome to the community!

Does the new router have the same SSID and password as your previous one, if not you will need to go through the setup process with all your devices again.


Yea, if you want them to automatically commect back, set the SSID and password to be exactly the same as the old. Make sure you have the 2.4 and 5ghz channels spectated on diffrent ssids, and make sure your phone is connected to the 2.4ghz when setting up the Wyze devices.


@WyzeJasonJ no the new router has a new SSID and password. I deleted the old switch, and went to connect a new device and it is telling me that no switch is found. It keeps telling me to check my internet connection and make sure my bluetooth is on which both are on. This happens also for my outdoor plug, and my thermostats. They just won’t come up at all either on my Android or an iPhone.

@IEatBeans Thank you, I will try changing the names and password to the old one but Eero doesn’t let you specify change the 2.4 and 5ghz on different ssids. It only allows you to turn off or disable the 5G for 10 minutes. So I disable it, and so that only the 2.4 band is on and try to connect but nothing.

I changed the SSID due to the fact that it was “Netgear” which was the name brand of my old router. I don’t understand why a new SSID would make the router undiscoverable if in the new setup I used the new SSID.

Thanks for your input on this.

1 Like

The watch issue could be a separate issue, Check you Android settings and go into the Wyze app permissions, set ‘Nearby devices’ to allow and see if your watch will connect now.

If you set up the devices again with the new SSID it should find them unless you are having another issue. You may need to make sure 2.4 and 5 channels have different SSID’s. as @IEatBeans pointed out above.

1 Like

The eero router when in temporary the 2.4Ghz band mode still does not show an available 2.4Ghz connection in my phone’s WiFi settings which in turn does not give me the opportunity to specify that band in the Wyze app setup procedure. So frustrating.

If you can’t permanently disable 2.4ghz, then your Wyze device (or any smart devices) won’t ever work

It’s hard to believe there’s no way to split them, try google

I googled it and you can’t separate them. There is only a temporary way to “hide” the 5Ghz network for 10 minutes. But according to the vendor that should be enough to allow you to setup any devices like the Wyze cameras, etc.

The SSID will remain the same, but you probably need to disconnect and reconnect, then try to associate your camera with the network. Saw a post on Reddit suggesting that if you don’t do that the QR code generated by the app has the wrong network information.

Thanks for the suggestion but that did not work either.

Try forgetting the network and then reconnect while only 2.4Ghz network is available.