Can't get plugs to connect

My Wyze Cams and Pans work fine but I can’t get the plugs to work at all. On Step 4, it asks me to connect to the plug’s wifi and come back to the app. I connect to the plug no problem, but then when I come back to the app, I just get a spinning ring and then it goes away with no error message. I can’t move forward from there. The plugs also make the annoying electronics chirping sounds, making me doubt the quality of the electronics inside.

Hi, @eyhkeyhk! One of the Mavens posted some instructions that may help you. :slight_smile:


Had the same issues, like the reply above… make sure your data is turned off and that your connection is 2.4ghz and try it again, it took me couple tries. hope this helps.

So I turned off Beam Forming but not sure how long it takes to have any effect. Then I noticed iOS had an update for 13.3 so I did that. After the upgrade, I noticed that during setup, the wifi information was already filled out vs before when I had to manually enter it and always failed. That seems to have fixed the issue and I can add more plugs without any of them failing.

I have to ask, why did you turn that off?

I read on one of the posts on plugs and light bulbs troubleshooting to turn it off, probably should have linked to it.

Had the same issue. My light bulbs worked just fine, but the Wyze Plugs required me to turn off cellular data (iPhone 13.3.1) before I could cross-connect the networks. After that, it was almost immediate.

1 Like

Guys… love the products, appreciate the affordability, but… it should not be this hard. IMG_2177.PNG|231x500

Smart pairing has not worked and when I connect to plug wifi, nothing happens. It’s still plugged in, just blinking. I’ve tried the 2.4 network, disabling cellular signal, manual pairing, the second plug that came in the package, and nada.

I promise, no haterade, just a motto - “It shouldn’t be this hard”
If it is more complex than you could explain to your own parents, make it so that it is not.

I am a fan. I love the vision, mission, and values of this company. You have presented a product that brings top notch quality to the masses at a price point that has driven you to the top of the charts on Amazon, TheWirecutter, etc…

As a technology (Army 25A) nerd, if I can’t get something to connect to my own network. It makes it a hard sell to anyone outside of the Alexa, iPhone, GoogleHome, HomeKit, Sonos world; aka those friends and family that call us when they have “computer” problems.

Best of luck and I am looking forward to iOS and internet application updates.

A. Hoff, BS, NR-P, CCP-C, FPC
Las Vegas, NV

Welcome to the community, @ahoff.medic. Mavens and Moderators don’t work for Wyze. We’re volunteers. :slight_smile:

If the information in the topic I provided the link to doesn’t work for you, then I would recommend submitting a support request to Wyze. You can also provide additional feedback about the difficulties you’re having with the plug activation process in the support request.

Support Request

You can also submit a request from within the Wyze app by going to Account > Help & Feedback > Submit a Log. This method will allow you to send an app log for diagnosis as well as report your issue. (Note that if you are using a beta version of the app, the log will be sent to the dev team rather than Wyze Support and will not generate a support request.)

I found my secret for connecting both the plugs and the bulbs. In the Wyze section of Location Services (which must be on), I ensured ‘Precise Location’ was enabled. Once I did that, everything worked well. Along with that, in the Settings ‘Privacy’ section, ensure Local Network is enabled for Wyze, I also had the phone in ‘Airplane’ mode. That was it. The ‘Precise Location’ enabled was the key for me.