Can't flash firmware to Wyze PanCam

After many months of flawless operation, my Pan Cam stopped working. I think it went bad flowing a recent update. It says it won’t connect. There’s no blue LED. But it is partially functional - when selected (using the Wyze iOS app), a single frame of video is captured and displayed, then nothing more.

Details of the misbehaving camera are here:

Having tried pretty much everything I can think of, I decided to try reflashing the camera with the current pan firmware from Wyze website (though the camera already reports that it has the latest:

I followed the instructions for flashing: downloaded the posted zip file (containing, unzipped it, renamed the flash image to demo.bin, copied to the root of a microSD card, put it in camera, and powered up while holding the reset button.

The instructions say: “Hold the setup button, plug in your USB cable, keep holding the setup button for 3-6 seconds until the light is solid blue, then release the button”.

I did so. The led never turns blue. When the USB cable was plugged in, the led turns yellow. It stays yellow. I held the button for 5 seconds, then 10, 30, 60…
Never turns blue. Stays yellow the whole time.

As far as I can tell, the image in the demo.bin file did not get flashed. The camera reports it has, as it did before. The led is off (indicating, one would think, no network connectivity). Yet I can click the ON/OFF button to turn the camera off and on.

If I kill the app (iOS) and relaunch it, it goes through the usual connecting/authenticating cycle, displays a single frame of video, then stops. A few seconds later, it shows “Connection has timed out - error code 27”.
The iPhone is on the same 2.4GHz-only WiFi network. I’ve tried two different access point to rule out WiFi/router issues.

Since the camera fails to flash the demo.bin firmware image (a process which is not dependent on network connectivity), I am coming to the conclusion that the camera has failed (even though it does sorta work).

I’m no expert, but if it were me I’d try flashing the previous version, Wyze devices seem to work better going in reverse :wink:.

It sounds like you do have a problem alright. The first option here is obviously to go the safest route and open a ticket with Wyze Support. If you do, be sure to detail everything you have already tried - it might help hasten the process if they don’t need to walk you back over the same ground. Also - try the phone option. I’ve had excellent results recently with them.
If you want to try another thing on your own, you can try a Factory Reset. After that you will need to update your FW, which you already know how to do. @Hemi‘s suggestion might be a good place to start, if the reset works.
Best of luck, and keep us posted.

FIXED! ( I think).

As reported in post #1, recently my Pan cam started acting very odd.
Today, I about to try flashing it with previous firmware, as suggested by @Hemi
I accidentally powered up the camera forgetting to insert the SD card containing the binary. Much to my surprise, the cam booted up and started working fine!

Powered down, inserted the SDcard, powered up, and it was misbehaving again.
Rinse and repeat: if the SDcard is in the camera, the camera doesn’t work properly. This behavior is perfectly repeatable.

Out of Curiosity
With the SDcard inserted, the camera gets into an odd state where it’s only drawing 180mA. I’ve measured the normal current draw at around 300 mA (with LEDs off). It appears that there’s something about the file structure or contents on the SDcard that forces the camera into a bad state. It appears to be alive, and will deliver one frame of video to the iOS app, but then it goes south.

I mounted the SDcard in my MacBook Pro and took a look at the contents of the card. It was about half full (17GB used out of 32GB). It’s a Sandisk 32GB High Endurance card.
The majority of the space was taken up by a lot of 1 minute long recordings of motion-triggered video, captured during February. There was a /log folder with a bunch of inscrutable log files (they appear to be encrypted so we can’t see what gets sent to WyzeHQ when we send in logs for troubleshooting). There was also a boot_log folder.

Using the macOS Disk Utility , I ran First Aid. It reported that the SDcard was OK.
I also used an open-source utility Grand Perspective to analyze the directory structures on the SDcard. No problem found.

I could open and inspect the contents of the various folders containing the recordings. I could play them back on the Mac. As far as I could tell, the SDcard was working just fine.

Using Disk Utility, I erased the SDcard, formatting it as MS-DOS (FAT). Put the SDcard back in the camera, and so far, it’s working fine. The only issue is that the blue led doesn’t come on. (yes - the led on/off option is set to on).

Since the camera is now operational, I see no point in flashing it with older firmware. I’ll leave things as they are for the time being and see if the camera continues to behave.

1 Like