Can't Connect to stream

I keep getting this error message on my Windows PC:

Oops! Something went wrong…

There was an error loading the page or resource you requested. Please try again later or contact us for assistance.

I just tested mine with a Windows 10 PC and it works just fine. Did you log into the my.wyze.com web site to try and view your cameras?

Logged on and off several times. Works on my phone, but not Wize Web View on my Windows 11 PC. Used to work. Not so for the last 24 hours. On HOLD with tech support now since the robot was no help…

1 Like

OK, after being on hold for half an hour, the technician told me that there was nothing she could troubleshoot and that she would have to forward this issue to another department via email. I might have an answer in 24 to 48 hours via email… I had already sent support an email, so this phone call was a complete waste of time without resolving anything…

1 Like

They will probably send a boilerplate reply email and it will not fix your issue.
I hope this is the page you logged into.

Yes, worked until recently!

Note that it still works on my Android phone, just not on the PC for some reason. Tried removing firewalls, anti-virus, etc just for giggles… the same results…

Unfortunately, the canned reply included all the steps on the website that I had already tried with no results:

Jonathan Q. (Wyze)

Apr 28, 2024, 1:59 PM PDT

Hi Stephen,

Thanks for reaching out to the Wyze Wizards team! I understand that when trying to access Wyze Web View, it fails to load. My name is Jonathan and I’d be happy to help!

Let’s try the following troubleshooting steps:

  1. Check if the camera model is compatible with Wyze Web View.
  • For compatibility, please refer to our [Wyze Web View FAQ](==
  1. Check that the browser has internet connectivity by trying to load [google.com]
  2. Confirm you don’t have a firewall or other settings enabled that are blocking WebRTC and [view.wyze.com]
  • If you’re unsure or unable to confirm, we recommend reaching out to your internet service provider.
  1. Ensure the desired camera’s live stream loads completely within the Wyze app.

  2. Make sure the firmware is up to date on the Wyze camera.

  3. In the Wyze app, navigate to the Account tab > Firmware Update.

  4. Restart the camera from the Wyze app.

  5. Navigate to the camera’s settings > Restart Camera > Restart.

I hope this helps! If you have any additional questions or concerns, please don’t hesitate to reach back out by replying directly to this email with a screenshot of the error and we’d be happy to assist you further.

Thanks for being a part of Wyze!

Jonathan Q. Wyze Wizard

Believe it or not, Uninstalling Microsoft 365 solved the issue. Did not have the issue before Microsoft 365 was added with my new software, but the issue went away after I uninstalled this feature… Can’t explain it, it just happened.

1 Like

I’ve never used Microsoft 365. I just purchased Microsoft Word many years ago for $65.00, a one time fee. Has Word, Excel and Powerpoint, all I need. :slightly_smiling_face:

Got my copy for $19. Who pays full price?