Cannot find specified network name

I’ve noticed a bug during setup. Wyze Cam announces “cannot find specified network name” during setup only to complete a successful connection a few minutes later. It creates the impression that setup failed when it was in fact successful.

Issue has been present for a while now (4 weeks or so).


Which camera (and firmware version) and app (OS version and app version) are you referring to? It is helpful when reporting a bug to provide as much information as possible. :slight_smile:


I too have been having this problem with a new Wyze cam, except it fails to connect, no matter how long I wait. When setting up, I have to manually type in the SSID but keep getting the “cannot find specified network name” response. I have three other cameras that have been up and running for several months. I was in contact with support, and after lots of trouble shooting, it was deemed defective and a replacement is on the way.

Sooo, just today, after getting back from vacation, I see one of the older cameras is offline. After deleting it and attempting to reconnect, I am getting the same error with that camera. Time after time, “cannot find specified network name”. I start to wonder if the apostrophe in my SSID might be causing a problem, even though the cameras in the past were set up without issue. The reason why I considered this is because it didn’t remember having to type the SSID in the past, so the name was a flag for me. I renamed my wifi network w/o the apostrophe, attempted to set up the camera, and boom, connected without a problem. Grabbed the “defective” camera, boom, connected without a problem.

I upgraded the firmware on both, hoping that might resolve the issue, but it did not. I changed the SSID name back with an apostrophe, and tried setting them up again and would get the name error again. Looks like you’ve got an apostrophe bug. So now my option is to change the SSID so all the cameras work, but will then need to reenter my somewhat long wifi password on all of my other devices in the house, which would be a bit of a pain.

I’m running ios 13 and the latest Wyze cam app.

1 Like

Thank you for providing this info, @tt1. I will pass this bug on to Wyze. :slight_smile:

EDIT: I found this topic from over a year ago, so apparently someone else had the same issue.


Thanks @DreadPirateRush. Wish I knew if this was something they’re going to fix soon. If not, I’d start the process of renaming my networks and reconnecting all my WiFi devices. Hard to believe only two people have been affected by this in a year.

Yes, I’m wondering how many people are having problems with this and giving up because they think it’s not fixable. I think it’s only certain special characters that are a problem. I use hypens and underscores in my SSIDs.

Good point @DreadPirateRush. Maybe something to stress in setup instructions for the cams to head off down-the-road problems?

You can bet that anyone who knows SQL will alert to a problem with an apostrophe in a field. I have no idea if it is the problem in this case, but if it is, the program is vulnerable to an injection attack.

I’m experiencing the same problem over here. I’ve been going back and forth with their support to no avail. I’ve tried downgrading from the beta firmware to V4.9.4.169, V4.9.4.108, & V4.9.4.28 firmwares and using the standard non-beta iOS app and still am unable to connect to my wifi with an apostrophe in the SSID. I have one cam that is connected to this wifi network just fine. It’s re-connecting other devices to this SSID that fail. I’m struggling here

Same exact problem. I don’t plan to change my network name. Too much hassle. My current cameras work great. New camera won’t connect because of the apostrophe. So frustrating. I’ve recommended these cameras to so many people and now I can’t connect. I’ll be sending back the latest purchase.

A possible workaround- if your router supports a ‘guest’ network, enable it, name it what you want and install this cam on it. A bit of a kludge but it works.

1 Like

Yep, same problem. Apostrophe in name so it cannot find the network. Very dissapointing and a regression from prior setups. I am returning my double-pack today.

Since I first posted about this I was waiting for the next app update before messing with my router settings. Finally gave up and two days ago created the guest networks and connected the troublesome cameras to that. Worked fine. Of course, the next day there was an app update and I’d be willing to bet the problem has been fixed. Anyone been able to give it a try?

I just bought my first camera and have been having this same issue. I’m about to just return it and get a different brand. This is ridiculous.

1 Like

I just updated the app. Now I can’t even type in the network name. It erases as soon as I type. No drop down list either. Very frustrating.

1 Like

I have the same problem!!! Looks like I’m gonna have to change my ssid name and redo 25 different devices on my network unless wyze comes out with an update to fix the apostrophe bug. PLEASE PLEASE PLEASE FIX APOSTROPHE BUG!!!

Same issue here.
Was this working in a previous firmware version that we can try?

Apostrophe’s definitely worked at some point in the past. Not sure if this is a firmware or app issue though. The only way I’ve gotten the problem cams to work is to create a guest network without an apostrophe and add them to that.

I have the same problem, camera was working okay and all of a sudden it get the message can not find specified network

None of my three cameras can connect, due to this issue.
I can’t do any name changes because the internet is at an assisted living facility, but all looks OK with name. Trying to protect my mom, as we had serious trouble in a former assisted living.
I’ve done all the suggested actions, to no avail.
I would never recommend wyze to anyone due to the poor, or, to be more accurate, zero customer service we have had for the last three years.
But we own these, so I am using them.
Well, not using them now due to this error: cannot find specified network name