"Wait for an app update"? Unable to find specified network name problem I'm facing, warning to others

Awesome set of products, awesome community around them. But… I don’t know about the longevity of their current model.

I’ll preface by saying I have a marketing and public relations background, and am also currently a software developer. The products, presentation and pricepoint vs. feature set is next to none when it comes to Wyze. After research and settling on some Reolink cameras, I just had to first try out the low priced solutions from Wyze.

I purchased the following:

  • smart home starter pack
  • two-pack of WyzeCam cameras (white)

Received the shipment on a Tuesday, installed and setup was just easy as can be (awesome). Some learning on the mobile app side, getting the lay of the land and seeing the degree to which I could tweak and adjust to my needs, still all good and happy. Then by Thursday I was pouring over all the requests for the API access - hoping to write some node.js custom integrations, but unfortunately, they don’t provide an API (yet?).

No worries, I’ll dabble with RTSP and then after that, and some IFTTT, I’d be all set and good to go and wouldnt need to touch anything.

Installation of RTSP went fine, and I was able to write my own custom Node.js RTSP websocket streaming backend and HTML5 streaming client (FFMPEG, Ubuntu, Node.js, PM2).

Now here comes my issue… last step was switching one camera to another wifi SSID (yes, 2.4) and changing the location of the camera.

Somehow during the setup process of this camera (that otherwise worked perfection out of the box) it (after scanning the QR Code) just ALWAYS replies “cannot find specified network name”… even when I try to return it to the original SSID that it was on previously and that 2 other cameras are on currently.

I then tried creating a new 2.4 wifi SSID, same result. I then looked for a way to clear cache in the app thinking it was unable to reset some value stored in the original setup process, I couldn’t find anything so I decided to do a factory reset, to set it up as I had originally (and I thought that it was due to the firmware upgrade to RTSP, then it would also reset that to stock firmware).

No dice, same results.

I then contacted support and spoke via chat with Ian, who did his best to help me trouble shoot (he was sharp and courteous). In the end though, the response I got? And I quote: “This is an app issue not your camera so we will wait for an update from our developers but I will also report this to our product specialists”. So I’m happy with the two working cameras, but dead in the water with one. Was on the fence about just buying a replacement, but nah, I’ll wait this out. Could it be that you just get what you pay for? It’s a shame, otherwise they are great! And the community support seems awesome.

P.S. - Wyze, if you want to be rock stars in this space and add a little ‘secret sauce’ to your model / reputation, add API access and the ability / option to access the local sd card through network file access. Trust me, you’re on to something but should re-think the cash grab model and give more power to your users. But I get it, it’s largely been a business decision. I’ll be closely following and encourage the community to keep providing great feedback to a really promising company / set of products!

if you work at Wyze the case number for my issue is Ticket number 20663


Welcome to the community @tamaker, and thanks for a thoughtful and helpful post. I’m going to tag @WyzeGwendolyn, who is the one here with the best access to the developers and the others like me, @Mavens, who just volunteer. I think she would like to see your post and could probably get eyes on your problem quickly.
If I follow your post correctly, your problems stem from entering the RTSP realm, which Wyze essentially provides but does not full time support or develop. That being said, have you tried the process of Manually Flashing that cam after the Factory Reset to current FW?. That might get you back online at least. I imagine Ian would have suggested that but it never hurts to ask.
Hopefully, either this will work or the others will have more ideas. Again, welcome and sorry you are having problems.

1 Like

Hi, thanks for the prompt reply. yes I tried factory reset (mentioned in my post), I actually tried that after realizing that RTSP was fully supported and I think breaks updates, so I factory reset twice on my own to be back in full production firmware compliance. Ian also suggested it during our chat session and I tried it again then, To no avail.

So after the Factory Reset, you were on the current firmware and still no success? I have heard of folks trying the uninstall/reinstall of the app with success - haven’t tried it myself, but sometimes it apparently does work.

1 Like

That’s correct. the last successful setup step for me is the voice prompt “QR code scanned”… then after clicking next and waiting a bit, I get the voice prompt “unable to find specified network name” (when using either a NEWLY configured 2.4ghz wifi SSID or the SAME 2.4ghz wifi SSID that the other two working v2 cams are using successfully.

1 Like

Have you actually been brave (or foolish) enough to try deleting and reinstalling, or even factory reseting, one of your other two cams that are working? That should, if they go thru the setup process successfully, rule out an app issue.
Where that would leave you with Support I don’t know, but it seems like a pretty good diagnostic if you want to chance it.
Keep us posted!

Great question @tomp - it’s immediately where my mind went as we reached the end of our trouble shooting attempts. No I decided against it, fearing I’d turn from curious to irate that I’ve shelled out (a nominal amount, admittedly) but have 1/3 of the cameras working. I’d instantly go from really proud of my new setup to being embarrassed at my choice of product!

In a nut shell, I’d rather keep the two working ones up and running and see how this 3rd camera issue plays out.

I’ll be sure to keep the community posted.

Great news. I’ve been able to re-download the current version of the v2 firmware and get it installed. So far the camera is working and back online. The software developer in me will undoubtedly try to reproduce this issue though!

Thanks all for your replies and help.

Wyze team, feel free to close the case - Ticket number 20663. But update your troubleshooting to include having the user manually download the firmware file (or an earlier firmware file) if the factory reset won’t work for them.

And because I’m a glutton for punishment, I’m heading back into RTSP / node.js socket streaming for a custom live feed grid of my cameras! LOL


Absolutely great news! But I do have to agree with your statement here.

Keep me up to date on your saga. I installed RTSP in one of my cams but wound up going back. I’m always interested in any new tips -never know!

@tomp I’m happy to report that everything has been up and running with RTSP and my home brew live feed grid (in addition to local storage and event recordings).

I see little quirks here and there (twice so far this week) where I need to restart one particular camera. I’m happy so far, but say a prayer nightly for access to the API to create some magic! May as well order a couple of the outdoor cams, still reading up on the details of it though.

1 Like

It’s a good solid product. Be aware though that to get the playback from the Sd card you have to pull the card. You can preset continuous recording but that builds large files that require download. Has its own base/WiFi so you have to be in that range to view but it will record off WiFi.
Glad to hear you are up and running! If you get the WCO, let me know what you think.

Thanks for tagging me in, tomp!

@tamaker, this detail level is fantastic and I greatly appreciate it. I’ll share this saga with the team and I’m glad you got your Wyze Cam running the way you wanted. :slight_smile:

By the way, we are discussing an API but I can’t make promises at this point.