Cannot connect to the network

Well I’ve read some fixes but my parents are 6 hours away and own only ipads. We have one v3 cam that says cannot connect to the network. Weve powered down and back up the wifi. Hes deleted the camera and started from scratch but it acts like its going to connect once he puts in the password and then goes right back to the ready to connect screen and says cannot connect to network. Any suggestions?

Have you tried disabling the 5ghz WiFi temporarily on your router?


Have you tried Factory Resetting the Camera and then try to load it back to the app?

How to reset your Wyze Cam v3 – Wyze

Also, if you have an SD Card in the camera, remove it until you get it connected again.


AND if you think you are going to need to troubleshoot for them more, I would encourage you to save yourself some headaches with this little trick.

You want your WiFi and password to match theirs. Or, can you create a sub WiFi network on your main WiFi network, using an old router - with their WiFi name and password.?

The idea is, if you must ask them to send it to you, so you can test/fix it, if your WiFi name and password matches yours, you can add it to your network, power it down and send it back to them. (Of course this would mean you use their Wyze account when you add it to your WiFi net so they see it in their app when they get it back.

Short story that might help make this make sense. My mom would visit my sister for days. And Sis would visit mom. Each time they had to reset/add their ipad and iphone to the other’s network. I suggested to savvy niece that she change one’s WiFi name and password to match the other - I didn’t care which one. She did and it solved all the problems. The device just reconnected to the same named network with password, 'cuz it didn’t know where it was.

1 Like

If the iPad has mobile data try having them turn off the mobile data setting.

1 Like

Both of my outside v3 cams did the same thing when I was doing a firmware update. Deleted cameras and added devices back in, same thing as your father did. Nothing, now I have two useless outside cameras and no security.

Great job Wyze.

I recently had the same thing as others on the thread. I got fed up with customer service and deleted both V3 cameras and went to a different brand that is capable of 5 GHZ for around the same price.
I will never buy another WYZE product again.

So ended up he bought it home. Cant connect to local network here either. Im not sure if he did a firmware update tonthis one or not. He cant remember. But when I tried to do it my house, same thing.

I have the same problem on mine as well. Is there a fix for this WYZE? I’ve tried al the resetting, turning off 5g… I have many other wyze cams, this the only v3 acting up. Just keep saying it cant connect to local network.

What has worked for me? Download an older version of the firmware, and install it. Add it to the network, then you can move up to the latest.

Are you using a 32GB or smaller micro SD card? It also has to be formatted to fAt32 not exfat before you copy the unzipped firmware file to it.
After getting the new file installed on the camera, use the app to setup the camera but after you scan the QR Code do not check the box and hit the next button until you hear the camera say that it is connected.
Then check the box and click the next button and the app should connect also.
Good luck.

I had to roll back the update. Its pretty easy once you get the hang of it. However wouldn’t have been so for my parents.