Cancel auto-unlock if bluetooth connects within 30 seconds of a prior auto-unlock event

Continuing the discussion from WYZE LOCK automatically unlocks randomly:

When my wife and I both go somewhere together and return together, the auto-unlock feature behaves in an undesirable way. Both of our phones are enabled for auto-unlock. Upon arriving at our apartment, the door auto-unlocks. After entering and closing the door it auto-locks as expected. A couple of minutes later the door will auto-unlock. If I don’t notice, the door auto-locks after 10 minutes.

I’ve only observed this extra auto-unlock when we both return to the apartment together. I’m presuming the lock recognizes only one phone initially and therefore unlocks for the 2nd phone some time after we’ve entered the apartment and closed the door. This 2nd unlock is highly undesirable as we often don’t notice it and it means our apartment is unlocked for 10 minutes.

You may have better ways to fix this, but here is a suggestion: When a phone makes a bluetooth connection with the lock, if it recently auto-unlocked (i.e. within 30 seconds), auto-unlock should be cancelled. In this way, the 2nd phone wouldn’t trigger another auto-unlock.

P.S. Can we get a ‘wyze-lock’ tag?

I wonder if It could be because one of your phones isn’t getting or keeping a solid geolocation from GPS, Maybe due to it being an apartment building depending on how may floors? I don’t get that behavior at all when my wife and I leave and return together. Just a suggestion since In order for auto unlock to work you have to first leave and then return from the geofence area and some people that have ha their door unlock when it isn’t supposed to have noticed their phone jumping around on the geofence map when they watch it.

We haven’t noticed any GPS instability in our apartment. We’re on a 2nd floor corner unit and location has always been correct when we’ve opened a map. Also, auto-unlock works pretty reliably for each of us separately.

@raym64 I wonder if it’s ever happened to you but you didn’t notice? I didn’t notice it the first couple of times because the 2nd auto-unlock often happens 2 or 3 minutes later when we are far enough from the door we don’t hear it. When it auto locks after 10 minutes we would not be the wiser. I started checking the history and could see the auto-unlock and 10 minutes later auto-lock had happened without me even being aware.

I generally wouldn’t notice since I live in a rural house and almost never lock the door during the day while we’re home. We only lock it when we leave to go somewhere and at night and I have auto lock disabled. But on the other hand, I’ve used the lock since February 10th and I go through the app often and I’ve never found a rogue unlock in the log while we’re home after locking the door for the night. I use the beta app and have searched my log a bunch of times trying to find one when helping other users.

@raym64 thanks for clarifying your situation.
I’ve only ever observed this behavior when both phones have auto-unlock enabled. If you don’t have auto-unlock enabled I’m pretty you’d never see this particular problem.

I may have written it unclear, sorry. We both do have Auto Unlock enabled, it’s auto lock that we have turned off. However, that said. Once we lock the door for the evening until the next day, I’ve never had a rogue auto unlock while we were home.

1 Like

Thanks @raym64. You’d probably have to enable auto-lock to get the behavior we see. Not sure why. I don’t want to try disabling auto-lock because we leave our apartment many times a day to walk our dog and this is the biggest benefit of the lock.

I have this same issue. Every time my wife and I return home the lock will unlock twice. Once for the first phone and then 2-3 minutes later for the second. Auto-unlock works perfectly for us separately and I am sure its not a geofence issue with the phones as I have homekit automations setup based on the person arriving home and they all seem to work perfectly fine when we both arrive. This has been a consistent issue since early access and it continues even with the new firmware update.

I am a new Wyze Lock user and don’t understand the need for geolocation; the door should only auto lock or unlock when there is a BLUETOOTH phone-to-lock connection within arms length. Why would I want my door to auto unlock if I’m not near enough to open the door? I live on the 7th floor of a condo building and I don’t want my door to auto unlock when I enter the geolocation area but I’m still several floors below my unit. Also, if I’m taking out the trash to the garbage chute down the building hallway, I don’t want the door to auto-lock if I don’t have my phone with me. Users should have the ability to adjust the phone’s proximity (i.e. one or two feet) to auto lock or unlock lock via Bluetooth only. If you are inside your home but just pass by the lock with no intent to go out, it should not auto unlock unless you are close enough to open the door. I don’t mind waiting an extra second for the door to auto lock or unlock if it avoids unintended operation and a security risk.

I don’t think the lock is sensitive enough to reliably distinguish between max bluetooth range and within arms length range. Therefore both requirements of entering geofence and being within bluetooth range must be met. If it only relied on bluetooth, the lock would be auto unlocking all the time when you are moving around your home.

1 Like

To give an example why this would not work, I live in a split entry home, meaning you walk in and stairs go up and down, so every time I go downstairs to the basement I walk within 12 inches of my door without opening it, so every time I went downstairs it would unlock. That is why the geolocation is added, you must be outside the geolocation for a time. Then when you enter the geolocation it starts looking for bluetooth, when it sees bluetooth then both things have been met and it unlocks. It is what also keeps my door locked when I go downstairs.

The lock isn’t designed to and shouldn’t unlock when you re-enter the geolocation zone. It uses Bluetooth Low Energy (BLE) And shouldn’t unlock until you enter the zone and then get within several feet or maybe a few yards in my case sometimes. You kind of have to have geolocation that you leave first otherwise the lock would unlock every time you walked by it in the house with your phone.

You seem to know a lot about the lock. Why is it that on my Android phone Bluetooth listing of devices paired, the lock is not listed but is shown below as an available device. Meanwhile, it seems to work on Auto Unlock occasionally. How does it do this if it isn’t paired.

I don’t know much about Android settings. However, If it’s similar to IOS, then it’s likely because the lock doesn’t use standard bluetooth. It uses BLE (Bluetooth Low Energy). BLE devices don’t always pair the same way as something like headphones. On my iPhone, it doesn’t even show up as a device ready to pair at all. Sometimes if I’m looking at the bluetooth device list, I can briefly catch a device called Ding Ding connected (I think that’s what it was, it’s been a while) and that’s the lock. You won’t see it there all the time. It only shows up and connects when it needs to.

1 Like