Can not find specified network

Greetings. I purchased 3 of these cameras and received them about 3 weeks back. All 3 set up and worked perfectly. I have one that has stopped working however. After researching, I tried rebooting the camera, and now it won’t connect to my network. I rebooted my modem, and did a factory reset on the camera as well, but it won’t connect. I’m using a 2.4 gh network, and it’s the same network the other 2 cameras are working on, and the one this one was working on as well, but all I can get it can not find specified network. I emailed in my support request on 6/18, but still no response. Anyone had this issue, and know how to fix it?

Is your phone connected to the same wifi network when you try to set up?

Here is the troubleshooting guide:

You may have to re-flash the firmware, or the camera may be defective and need to be exchanged via your support ticket.

Yes. My phone is on the same network. I guess I’ll try to flash it then.

I just re-flashed my camera with latest fw and it still says cannot find specified network name. All other wyze v2 cams that I have successfully connect to my network.

Any ideas what I can try to make my camera connect to wi-fi?

Make me wonder if this particular cam has a wifi radio problem. Have you submitted a support ticket?

I’m having the exact same problem. Did you get it resolved? If so, how?

I’ve had this same issue, I was able to resolve it by flashing and older version of the firmware ( Once flashed, I was able to scan / find network / add the camera to the app. Once added it prompted to update the firmware. (

I am not going to play around with firmware versions, this product is supposed to work out of the box, if it doesn’t I am returning it.

Yes, you’re right. It should work out of the box. Keep in mind though, firmware updates are done for several reasons. (This is true with almost all IoT / Smart Home devices)

  • Bug fixes
  • Feature updates
  • Security updates

You usually have the option to leave your device(s) exactly as they are out of the box. However, some companies push updates to your devices without asking you, first. For example, my Google Home and Roku devices update without my permission. Wyze does NOT force updates on you.

Own 3 cameras, moved one to test possible location for 4th. worked well, placed back in original position. Wont connect. Restarted camera, router, app, phone, removed and re-added to Alexa. no fix. camera made weird sounds at end of pre-records. Tried a flash of:

. Got “Connection time-out re-scan QR” message twice. Then worked fine.

Perseverance seems to pay off.

1 Like

I tried unsuccessfully to add a new camera until I noticed in my Settings my wi-fi had two home connections/names, I chose the old one (also the one the other 3 cameras are on) and that fixed it and it connected.


This can happen if your router has a space at the end of the SSID ("name " instead of “name”). Best to fix the SSID in the router.

1 Like

I had same problem untill I set phone with wyze app to same wifi as cameras set to.