Cameras won't connect after firmware update

I too am experiencing an issue with the Wyze Cam v2 after the firmware update, however I got the update a couple days ago, and last night out of nowhere, i lost connection. I use the camera everyday for my children and have had it over a year with no issues what so ever. I also can normally fix an issue like this…

I have the wyze pan cam as well and all is fine with that camera, I also have another wifi camera and is working with no issues. Here is what I have done. After it saying internet connection issue on the app, I restarted both the camera and the router. So I deleted the camera and tried to set it up again, and now I am getting “cannot find specified network”. I have tried 2 different routers both being on 2.4ghz and no vpn here. I’ve uninstalled/reinstalled the app, and I am now trying to go back to a different firmware, however I may be confused on that. I put the demo.bin on a sd card and put it in camera and held the button while plugging in power cord to try to do the firmware upgrade, It states that the light should turn solid blue however it does not and just says “ready to connect”. How do I know if I am successfully updating the firmware?

Any help would be nice.

i was having same problem after updating today. Here is what I did to fix it. I unplugged the wyze came and removed the sd card and put it in my computer. The computer said something about the SD card being currupted, and asked if i wanted to fix it and i clicked YES(but lost all footage on sd card)…after that, i put the sd card back into the wyze cam and plugged everything back in. Worked on the 1st try. no issues since.

1 Like

I’ve had the same issue. It first started after updating my cameras with Person Detection. One day my Pans were working the next day they were not. I tried everything except SD card because I wasn’t using the cards. I also tried a brand new V1 and I cannot connect these cameras. The rest of my camera network works, for now.

I submitted a ticket with support but have not heard back.

Even a V1 I get “cannot connect to network. Nothing that I know of has changed.

Okay guys I totally forgot to check my phone was connected to 5ghz. The new Xfinity router shows up as one address. Not split.

Anyways Jacque from Wyze support helped me.

All units are working.l now.

1 Like

I was having the same problem after the latest update in July. The camera would either get stuck on a day and not connect or just go offline and not be able to reconnect. After power cycling numerous times and uninstalling/reinstalling on my app, the tech guy I’ve been talking with via email suggested flashing the firmware. I flashed back to the April version and so far so good. It prompted me to update and I’m going to choose to wait until the next version so I don’t start having all the connection problems that came with the July update.

Welcome to the community, @swolz! Thank you for your contribution to the forum. I’m glad you have resolved your issue with the firmware flash. Could you please specifiy which versions you are referring to? “Latest”, “last”, etc. are subjective depending on when a person reads a post. This would be more helpful to anyone else reading your comment. :slight_smile:

Sharing here in case someone finds this useful:

I was having a terrible time with one of our WyzeCams, I tried flashing, factory resetting multiple times with different firmware. Nothing seemed to work. It would sometimes connect and then disconnect after turning it off.

I narrowed it down to a wifi connectivity issue, and noticed that it would replace an underscore (_) in the wifi name with a star (*) (all my wifi names have underscores).

So I tried something really simple with a wifi repeater/extender - I set the extender wifi network to a simple name, all lowercase. Now it works like a charm! So consider renaming your wifi network if it has underscores.

1 Like

Excellent catch and well described!

I’ve had similar issues with the names and passwords of various WiFi devices over the years. The rules published on the web for acceptable characters to use do not always apply to every device!

First testing a simple WiFi SSID and password is excellent advice when troubleshooting connections! :+1:

(Interestingly, I have underscores in some of my SSID names and my Wyze cams still connect, but the advice is rock solid since I also have no idea what router this person is using)

I tried the new setup again but not working now I have no security in my house, what do you recommend?

Can someone give me specific steps for the “firmware flash” resolution? I plugged in a camera I hadn’t been using for awhile (in a new place), and it was working fine last night - until, as everyone in this post has mentioned, I “upgraded firmware,” in order to get person detection. Since then, I get all the same prompts to resolve the connectivity issue, none of which have worked. I submitted a ticket through the app. Wishing I had ignored the upgrade message, which is what I usually do with Wyze and for my other cameras (both the same model and still working fine).

Firmware flash instructions for cams are located here. The only thing missing is that you need to use a 32GB or smaller microSD card formatted to FAT32 (or MS-DOS (FAT) on a macOS computer).

1 Like