Wyze Cam V2 Stop working since last week

Hello all,
I have Wyze Cam V2 Model WYZEC2, and last week it stop working. it was offline and it was giving me error 99 or something of that nature. For 1 week I been doing all kinds of troubleshooting and resting and factory reset. I even tried uploading the image or firmware via USB and holding the reset button for 6 seconds none worked. I used hours of online search and Youtube. I contacted Wyze support and no help there either.
My Current issue is Wyze Cam V2 will turn on and I get message ready to connect so I scan the bar code and wait for connection then it fails to connect. I rebooted my router which is google Nest wifi and i added new Mesh point google nest wifi so i have 3 now in my APT for better coverage. This cam won’t connect and frankly speaking, i am not sure if this cam even took the new firmware via USB but i am out of ideas can someone please advise Thanks in advance

Trash it and move on

That sucks i like these cams and they work so well i feel bit sad to let it go i am hoping i find a way to fix it so it works again

I wounder if this an APP issue since the updated the APP last week or if it is Firmware issue since they push 2 updates last week and this week

I try factory resetting it and an SD card firmware upgrade of regular Wyze firmware for V2 but i really think that did not complete properly or it did but i am not aware if worked

My understanding is you put the file in SD Card and rename to demo then insert the card and hold power rest button then power on the cammera then hold for 6 second then relase and leave it for 5 munites

If you’re getting “ready to connect” then the firmware is already working. You might try configuring it on a different router temporarily, preferably where the 2.4 GHz network has a different SSID than the 5 GHz network.

I just had a similar issue. 2 cams bought at the same time, one stopped working and won’t reconnect, the other connects just fine on two different phones. The “broken one” just keeps clicking and is yellow.

Do we just trash it? How long do they last?

Your warranty is 1 year mfg. Warranty if so open a service request at Wyze

1 Like

Mine is almost 4 years old. The one that seems to have failed was not used much and not at all in the last two years until yesterday. I guess I will be buying a new one. It worked yesterday but stopped working today.

You could certainly try re-flashing the firmware with an SD card. There is a decent chance of bringing it back to life.

Wow $20.00 for 4 years I would say you got your money’s worth for sure