Cameras no longer work on IoT subnet

With recent software upgrades the cameras no longer work when behind multiple NAT firewalls. They work fine if there’s only one firewall, but not more. I put all my IoT devices on a separate subnet that is behind a second NAT router/firewall. This worked up until about November or December 2022, but no more. I downgraded the firmware, but it still doesn’t work. (It might require downgrading the phone app too, but I don’t think that’s possible.)
So no more Wyze cams for me. :frowning:

It’s odd that it doesn’t work. I don’t know if it was an accident or on purpose. If an accident then I’d guess that the software is detecting firewall configuration incorrectly - maybe using a buggy version of libnice. In any case, this sort of setup should work. The NAT routers will establish return routes once packets are sent out.

1 Like

More likely something strange in your networking. As long as the networking is not messing it up, it should not matter how many routers are in the path.

1 Like

Can you give it a try and see if it repros? I’d love to hear that it works. Or get confirmation that others experience this too.
I tried a lot of variations of network setup and routers. I couldn’t get double NAT routers to work.

I have run Wyze devices on double nat for a while, only recently did I switch away. I had no issues with double nat. Are you sure it’s not something your firewall is blocking? What happens if you disable it?

Yeah, worked fine for me for years! Until recently - like November or December.
I didn’t change anything about my firewall. ;/
And I did find that if I enable wifi on my border router (the modem) that it works. Which is then essentially just a single NAT firewall.