Camera v2 Pan not showing thumbnails of recorded events

Updated after more experimentation:
I have 3 v2 Pan cameras: 1 in service for ~2 years and 2 new ones. The old one records events and shows a thumbnail which expands when clicked on. A play button next to it just prompts to sign up for Cam Plus.

The two new ones trigger on motion and I can see events in the log. But, there’s just a picture of the camera and next to that an SD card logo. Click on the event and I see a default image of an out-of-focus living room. But, click on the Playback SD icon and I get taken to the recording.

All have Detection Sensitivity on high, Motion and Sound detection enabled, All day schedule, Notifications enabled and the Bell icon on the main page does not have a slash through it. Livestream and playback work on all 3. Something is just broken with the Event thumbnail on the two new ones.

The old camera firmware is v., the new ones are 4.49.125. I wonder if the firmware is the problem… I have not updated the older cam as yet.

Phone: Samsung S10+, Android 12, Wyze app is v.

Hello @NivaR,

I am sorry this is happening. Your older camera sounds like a Pan v1 since is a Wyze Cam Pan v1 firmware and is not the most up to date for that unit, the up to date one would be The other two cameras that are on are both Wyze Cam Pan v2 and are both also very out of date on firmware. The current for those is You may want to try updating all of them and see if it helps.


The 2 new cameras state that the Firmware is up-to-date and that all is well. Additionally I note that I get phone alerts from the older cam (v1) but no alerts from the two newer ones even though both have events recorded…

I don’t want to update the firmware on the older camera. It is working and I don’t want to risk it.

Check in the bulk firmware update page (account > firmware update) as well as the cams settings > device info > version. They may be so old they aren’t even able to update. You may need to flash the firmware manually

Both new cams on that page show Up to Date. I got the cameras directly from Waze about ten days ago. How do I flash firmware manually?

Plugin versions are for both new cams. What puzzles me is why the older cam works fine.

I found this regarding updating the firmware manually:

But, it is not clear how I’d get the firmware on the SD card. I tried connecting the camera to my Mac using the USB cable but it does not map as a drive. I don’t have a separate SD card reader either. Am I out of luck here? If so, I’ll look into a return.

FWIW, the release notes page says my current firmware is about a year old. None of the two subsequent updates address the issue I’m having.

You will need to use a 32 gb or less micro sd card to update. Is there a reason you haven’t updated the cams in the past? It’s best to keep any device up to date at all times for security and bug fixes

I bought two 32GB SD cards with these brand new v2 cams. I got them about 10 days ago so I don’t know why I have to manually update the firmware. The cams say they are at the latest release. I have no ability to access these SD cards apart from putting them in the cameras.

Oh so they are new cameras. That makes more sense.

It should let you update OTA, have you tried power cycling them?

Power cycled (wall plug) and restarted (using the app) several times. The new cams assert that the firmware is up-to-date.

Odd. Have you tried factory resetting them?

Didn’t know that was possible. Will look into it.

Adding screencaps.

I factory reset one of the two new cams. Firmware rev. “Everything is good! Your camera is up-to-date.”

Still no event thumbnail or alerts.

Same here.