Camera thumbnails not refreshing on home page - any ideas?

I have (2) Wyze Cam V2 cameras that are setup exactly the same. When using the App, only 1 of my cameras will update the homepage thumbnail after I view the camera. The other camera refuses to update the thumbnail and only seems to randomly refresh every couple of days. They are both on the latest firmware and I am using the latest app. I have tried rebooting the camera in question several times and nothing seems to remedy the issue. I log into the camera to view and exit and the thumbail never changes. I do the same on the second camera and it updates immediately. The camera functions just fine when I go into live view and has no problem recording events or video. For some reason, it refuses to update the thumbnail though on the main homepage. Does anyone have any other ideas?

The thumbnail won’t update until you actually show the live stream of that camera.

Right - I go into the live stream and exit and the thumbnail does not update on camera1. I do the same thing (view the live stream) on camera 2 - exit and the thumbnail updates just fine. I just deleted the app completely and reinstalled on my iphone and viewed both live streams. Camera 2 shows a refreshed and updated thumbnail back on the main home screen but camera 1 now just shows the generic wyze cam picture as the thumbnail for camera 1. For some reason this camera refuses to refresh its thumbnail after I view the stream. Everything else seems to work perfectly on the camera.

In order for the community, and Wyze, to assist you better, please always provide all of the following.

  • Phone/tablet type and OS version on phone/tablet
  • Wyze app version (instructions here)
  • Firmware version installed on Wyze device ( Device settings (gear icon top-right) → Device Info → Installed firmware version)

This is needed because “latest” and “up to date” are subjective to when a post is added to the forum. (It is also important to distinguish whether an issue is actually with a beta version, as opposed to a public release.)

Newest Everything. IOS 13.3 . Wyze app version = V2.7.29 and Firmware on both cams =

If I put my 2 cameras in a grouping and view the live stream and exit - the first one displays "connection failed (error code - 20015) for about a millisecond and then continues to function without any issue. I am guessing whatever is producing this error is the reason the thumbnail will not refresh. However - everything else seems to function perfectly with the camera.

Since it’s momentarily reporting connection error, have you tried rebooting the router?

Yeah that doesn’t seem to help. The only luck I’ve had was changing it to SD momentarily and then back to HD and that seems to refresh the thumbnails. It seems like some type of programming glitch.

I am seeing the same issue on my setup…one update and the other cam stagnant…

I have 2 cam pans and 1 cam - the cam pans update the thumbnails after each time I open the cam a view the scene; the cam is not updating.

I have iPhone 6 and the most recent updates to all cams. I’ve tried pulling the screen down to refresh, turning the cam on/off/, changing viewing mode (SD, 360, HD) and nothing seems to work. It would be nice to see a recent or even current thumbnail rather than an icon or a night shot that becomes the thumbnail.

Any suggestions?

Thumbnails only update after viewing the camera live feed. They don’t update with a swipe. However, you may be interested in this #wishlist topic.

1 Like

Same problem. iPhone6, 2 cams (one white, one black) and a PanCam. The white cam’s preview does not update after viewing the live feed. It may update in a few days for no apparent reason.

Same problem. I have 3 cameras. The live feeds work fine but the thumbnails on the Home tab don’t update after viewing live feed. They used to update after viewing live feed, not sure when this stopped working.

Same problem. I have 25 v2 and 2 pans. Thumbnails are not refreshing. Opened a ticket. I had to kill and reload app to have thumbnails updated. Very inconvenient !

Installed older version of the wyze app, no thumbnail refresh issue.

It is another bug introduced by the Wyze development team in Android v2.10.36
Here is another thread about this: On Select-Camera page, confused by the photo image that's displayed - #5 by myswtest

It’s working for me now, consistently

I just started seeing this issue yesterday, 7/29/21, after updating my equipment. None of the thumbnails or connection status icons on the home screen are updating on all of my Wyze Cam V3s or Front Doorbell Everything works fine in live mode.

I updated my Wyze app to v.2.22.31. I also updated the firmware on my Wyze Cam v3 cameras to v. My doorbell is running firmware v. I am using a Samsung Galaxy S21 5G with Android version 11. Everything is updated to the latest and I have tried to force shutdown the app with no affect.

I’ve seen this happen off and on for some time. It usually goes away after I reboot the router.