Camera Thumbnail on Home page not updating properly in the Android application - Cam Plus

This topic is about the thumbnails on the home page/tab and not the thumbnails on the event tab.

Android OS: 13
WYZE App: v2.45.6 (361) updated to v2.46.0 (368)
V3 firmware version:

One of my CAM PLUS V3 cameras will not update its thumbnail on the home page unless I view playback for that camera. The camera records motion events and sends notifications without an issue. Even when new events are found for that camera in the event view, the thumbnail on the home page for the camera does not update. Should I choose to view an event, then go back to the home page, the thumbnail for this camera is not updated.

Things I have tried:

  • Clear cache in app | force stop app | clear cache via Android settings for app | reboot phone
  • Uninstall the app | reboot phone twice | install the app
  • Remove camera from CAM PLUS service | clear cache in app | force stop app | clear cache via Android settings for app | reboot phone | add camera back to CAM PLUS service
  • Renamed the camera
  • Edited the camera thumbnail up and down the home page
  • Power cycle and reboot of camera
  • Left the camera powered off for over 4 hours
  • Grouped and ungrouped the camera with others that do not have the issue

I am trying to avoid removing the camera from app and then adding it again. It seems like that might be the next logical step, but with the camera location, the detection zone, the rules…it is nothing I want to roll the dice on.

I did find a very old topic about this same issue, but it was with a V2 camera that was not CAM PLUS. Also, the application functionality has changed since that old thread. Nowadays, the thumbnails on the home page should update every time a new motion event is recorded.

Is anyone else noticing this?
Has anyone been able to resolve this issue?

1 Like

I have all my cams in groups so I never see thumbnails. But I have seen this occasionally when initially installing a Cam or moving it within the app to test something or change groups. I have also seen it reported here in the forum. I didn’t see grouping and ungrouping the cam on your troubleshooting list.

Beta 2.46 is nearing release, in Beta RC round 2 right now, perhaps that will bring a resolution.

Thank you for the reply and acknowledgement that others have had similar issues in the past. I just grouped the camera with another and then live streamed each while grouped. I then ungrouped the cameras. As expected the home page thumbnails updated. (Some form of streaming Live/Playback always results in an updated thumbnail.) I then decided to power off the problem camera. I am going to leave it powered off for at least 3 hours maybe more. I will then see if anything changes from there. Maybe something is hung up in the WYZE cloud for this particular camera? I have also thought about installing the app on a different android device to see what happens…


1 Like

I have a few cameras that are not in groups. From my observations, the thumbnails never update automatically. They show the last image from the last time you looked at that camera. This is the case with at least V2, V3, OG-Tele, and V3 Pro. My other camera types are all in groups. This applies on both Android and iOS.

There was a recent change to the functionality of the home page within the app. Nowadays, the camera thumbnails on the home page should refresh with the latest motion triggered event thumbnail for that particular camera.

All of my other cameras (v2 and v3) function this way. However, the problem thumbnail (I hate to say problem camera) will not update unless I stream from that camera.

Side note: I suspect eventually the group camera icon currently found on the home page will be replaced with the latest event thumbnail from the last triggered camera within the group. This would be neat functionality for those that use groups and would likely make grouping cameras much more beneficial.

I pretty much always have the latest beta release of app software on at least my Android phone and iOS phone (my android tablet is often behind by a bit because it hardly ever gets used).
I have not observed on either phone that the thumbnails update on either phone for any of my cameras that are not part of groups. Just looked at both phones to confirm this. Some were a bit hard to tell when the image was taken, but one has a large display digital clock in the field of view (not what the camera is really looking at, but it’s visible), and it is showing an image from late August. That camera gets events every few hours (often more often than that).

Well that is interesting. I am sorry to hear you are experiencing the same issue across all of your devices for all cameras on the home page. Fortunately only one of my cameras fails to update on the home page. The thumbnails just auto update and I never leave the home page.

I left the camera off for over 4 hours and powered it on. It has since recorded a half dozen events. The thumbnail on the home page remains from the playback I performed prior to powering the camera off. The group and ungroup of this particular camera had no impact on how the home page thumbnail updates. All other camera thumbnails on the home page continue to auto refresh/update.

1 Like

Have you tried dragging down, hold, release to refresh the home page?


So many times that I wore out a spot in my screen protector. (Kidding of course, but yes.)


I failed to mention something else I have noticed. If I clear the app cache the thumbnail reverts to an image that is extremely old and will remain until I stream from the camera. As mentioned, any sort of streaming from the camera is the only thing that updates the thumbnail on the home page.

I now have an additional v3 camera exhibiting the same behavior. The second one is tied to a Cam Plus Lite subscription versus a Cam Plus subscription like the original camera. Same deal, when I clear the app cache the thumbnail for that camera on the home page reverts to a very old image.

By the way, I noticed the second camera issue prior to installing the latest Android release of the Wyze App: v2.46.0 (368)

The problem persists with the latest release. Personally, I am beginning to think this may be a WYZE cloud issue. The only reason I am leaning that way is due to the old and very stale thumbnails that appear after clearing the app cache.

When I spoke with a WYZE support person the other day, for a different issue, I happened to mention this issue as well. She told me removing the cam from the app and then adding it back will fix the thumbnail refresh issue.

Initially I did not want to do this. However, I noticed a third camera not refreshing now. Thus I removed all three and added them back into the app with the same name. Fortunately the rules all stuck, but I did have to go through detection zones and advanced camera settings for each of them.

I may know how to create the problem, but will test that theory after I know the suggested fix above works properly.

I don’t like the solution, but it worked. Unfortunately I have not been able to reproduce the problem on demand. I’ll be keeping a close eye out for what causes it…if anything on my end.

It sure is nice having all of the camera thumbnails on the homepage refresh to the latest event thumbnail for that camera!

1 Like