Camera seems to need access to all photos?

I am experiencing what I perceive to be a change in Wyze app saving an event to photos function. I am asked as usual in a popup whether I want to give access to select photos or all photos. However, I can’t pick access to select photos, only access to all photos. And of course can’t save the event unless access to all photos is given.
I’ve played around with this and changed Wyze access to photos through the ios settings app as well through Wyze events. And continue to experience the issue no matter how I choose access.
The choice of access to select photos has always worked before to let me save an event on all my cameras.
I’m puzzled.
All my cameras are up to date,,, and base is at

I had the same issue the other day using my iPhone. It used to give access to select photos but that wouldn’t work any more so I also had to switch it to all photos to be able to download a video from my V3 to my phone. Maybe the new IOS app 2.20.142 screwed it up?

1 Like

Thanks @Antonius. That could very well be the answer. I noticed the Wyze app was updated on my phone May 12th. And I read back through the update notes for several iterations to find any mention of a change to access to photos; didn’t see anything. I submitted a question to Wyze support earlier today asking if a change had been made to the app that requires access to all photos. I’ll report back if I learn anything.
I will not give Wyze access to all my photos. There’s way more information about my life in those than I want to share with Wyze.

The Allow Photos Access to “All Photos” permission for IOS appears to be a regression introduced in version V2.20.142 of the IOS Wyze app. The previous version of the Wyze app worked with the “Selected Photos” setting.

I will submit a support request. Please also submit a support request if you are reading this and are affected by this change!

I agree. I submitted a problem report/question 11 days ago and have heard nothing back. I’ll report it again since it is still a problem. Really annoying to lose functionality that I use pretty often.

@wize-guy I found another forum thread specifically about V3 cameras and requirement
for access to all photos in order to save events. A forum maven is part of that thread. I posted that I have the same issue in order to follow and get updates.

Well for now instead of downloading the event videos I just tap the share icon and email them to myself and store them someplace else

1 Like

Glad you are able to to share by email snd have a work around. Unfortunately, I have the same problem with the Wyze app wanting access to ALL my photos when I try to share an event. Weird,

@omgitstony Adding you to this related thread

1 Like

This is the issue discussed in both threads. Before the app change select photos worked, now it is all photos or nothing. I asked a Beta tester who is testing the new iOS App. and the same thing happened.


Why would WYZE need access to shared? I am saying if I watch the event video and if I want to download it or share it I use the share icon, it never goes to my phone album it just goes where I share it to.

1 Like

Likely just a bug that needs to be reported by those experiencing it. Send a log to Wyze.

1 Like

@Antonius The share button you circled gives me the same “All Photos” popup as the download button.

I just sent myself an event videos from one of my outdoor cams, not on cam plus. It went straight to my email and it is not saved in my iPhone photo album at all. This is what I get when I tap the share icon, I can send it anyplace I want and it doesn’t save to the phone unless I choose that.

Just ran across the same issue. I tried to save off video by some other method but iOS app won’t even let me get around the photo access issue. App was able to send me directly to memory card to try and record off timeframe from storage, but that’s always hit or miss with trying to get recording starting at right spot.

Any word on an app update to fix?

I’m having the same issue. Any update on a fix? I also just emailed support about it.

I have not had a response from Wyze in all this time. I am guessing this change in behavior is a “feature” at this point.

ok. thanks for letting me know.

I’m now getting error codes and crashes when trying to save to photos or send along to something else without allowing full access to all photos. Submitted ticket but then got the audacious response that I would have to reach out and contact someone for ticket to be looked at. wow.

They must be making BANK of all our personal photos and private info!! :imp:

If not then put the tickets in queue and work off. How hard is that? Yet another case of the WnDRfL WyZe customer service. Good thing these things are cheap!

This has been discussed in the post below. Fact is for now you have to give access to all photos with iOS .

1 Like