Camera initializing

I used to love these cameras but am now super frustrated. I unplugged one of my cameras today and plugged it back in and now all I get is the solid yellow initializing light. It never does anything else. I need to connect it to another WiFi network. I assumed that the camera was dead so I went to Home Depot and got a new one. Same damn thing. Plug the camera in and just get the solid yellow initializing light. Any thoughts on what could be going on or do I have two dead cameras?

How far are you from your wifi and how good is your power?
I’ve had to set up cams near my router before placing them in the far end of my house. Once there they worked fine,
I’ve also had problems setting up cams with long (26’) 3rd party USB cables, revert to OEM all OK for setup, then I could use the third party long cable…

I tried three different power cables- all which came with the cameras. I’m also about 15 ft from the router.

Is your router 2.4 GHz only, or 5 GHz only, or dual band?

Dual band. I have google nest and I have two other Wyze cameras working on the wifi