Camera Failing To Connect / Can't Login To App

I have 4 cams, all v2, all updated with latest firmware. Yesterday, 1 cam stopped working (other three seemed fine).

App couldn’t connect to this cam (others worked). When trying to connect in app, eventually gave error code 60 (“Please try to power cycle the camera”). Did power cycle, came back on with light flashing yellow, then quick blue, then off (no light). Did factory reset, still can’t connect. Light is now flashing yellow.

Tried to remove/re-add cam, but app says “delete failed”. Logged out of app, did force quit, now when I try to login (yes, uid/pwd are correct), app just briefly shows progress spinner - can’t login.

This camera may need to be replaced. But, you don’t actually need to delete it from the app to set it up again. It seems the app is hung up now. I would try deleting the app from your phone and then re-downloading it. Login again and it should show all your cameras. Then click the plus sign and try to re-add this camera using the standard setup procedure.

If that doesn’t work, you may want to review the steps here:

If that doesn’t help, you can try re-flashing the firmware:

And if all that fails (or you’re not comfortable flashing the firmware), you should file a support ticket.

I already tried the Troubleshooting Guide.

I just uninstalled the app, and reinstalled. Now, when I launch the app, I get the Wyze Cam title screen, then a few seconds later it shows “network timed out”. I’m not having any problems with any other devices on my network. Now what?

I think at this point you’ll need to file a support ticket on this issue.

Just did. If Wyze is able to get back to me with info that may be helpful for others, I’ll post it here.

For the benefit of anyone else who may be having this kind of trouble:

Turns out my router was blocking Now I’m able to login, and delete/re-add the bad cam. (Still not sure why this one cam messed up to start with…)

1 Like

How do I get around wtih " Turns out my router was blocking " .

Can you please share more details ?


Check your router logs. Each router is different, so I can’t say exactly how/where to look. I noticed that “” was being blocked. Once I whitelisted it, things worked fine. The app needs access to that domain for the login to work (probably other things, too, I dunno… but if it’s blocked, you definitely won’t be able to log in).

1 Like

I had a similar problem few days ago. I was able to view WYZE videos at work using company WI-FI before. But it stop working yesterday. It worked again by using cellular signal by turning off WI-FI. I guess the router at company blocked it. Hope this helps.

Same problem for me. Just recently - last few days, I can no longer get connectivity from my Wyze App (Android) to Wyze cam while at work (using Comcast WiFi). The app either acts like it has forgotten my password, it just sits there at the launch screen. If I disable WiFi, it works fine (and chews up my cellular data).

Hello @BillH, have you tried deleting the Wyze app then reinstalling it back onto your device?

Yes, I tried reinstalling a couple of times, but it did not help. I checked with a few co-workers who also have Wyze cams and their apps are behaving the same way. Problem seems to be with authentication. One way it will work/stream is: 1) turn off phone’s wifi, 2) start Wyze app using cellular data, 3) turn on wifi, 4) watch livestream.

1 Like

Okay thanks for the info, I’m going to send this information over to the Wyze team and see if they can take a peek into this.

One explanation for this may be: the communication channel and ports used for authentication and initial connection to the camera is different than the actual streaming. The wifi router may be blocking those initial channels and not the streaming which is why you may be able to stream after initially connecting over cellular.


I’m leaning toward Loki on this one. We’d recommend checking with your IT people to see if that’s what’s going on. If that isn’t it, then we can go from there!

You and Loki are right. IT closed some ports on the router due to some people using the guest wifi in unsanctioned ways. Thanks for looking into this anyway.

1 Like

You’re welcome, BillH! Glad you were able to get it sorted out with the IT department. :slight_smile:

Thanks for taking the time to update us!

FYI, I am new to the Wyze products so wasn’t sure if my problems where user errors :slight_smile: I was happy to see that others are having/had similar issues. The problem you work out with BillH starting Feb '19. I.e. app having issue over wifi connecting to cameras however connect fine over cellular. This is going on over personal wifi and question is what port/ports should I investigate on my router?

Also, has a side note app also periodically displays “Device is offline (error code 90)”

Sorry to hear you’re experiencing that! I would recommend getting in touch with our customer support team about this.

Wyze Customer Support