Cam V2 bricked after Firmware update and Wyze refuses to honor warranty

The latest update bricked a Cam V2 that is less than 9 months old and all Wyze will do is offer $15 towards a V3 at $32. It seems that Wyze will not honor any warranties that they promise. I received the following:

Thank you for your patience. I hope everything went well with you today. I’m Riezell one of the support from Wyze and I’ll be taking over this concern on behalf of my colleague. I’m sorry to hear that you are experiencing a solid yellow light on your Wyze Cam V2.

Unfortunately, the v2 cameras are no longer in production and we cannot issue replacements at this time. We apologize for any inconvenience this may have caused. However, we can offer you a $15 store credit that you can use on your next purchase. Please make sure that you have an account with Wyze for us to credit your account. You may visit to create your account.

Please let me know if you have agreed to our offer and have made your account with Wyze so we can proceed with assigning your credits.

Thank you and looking forward to your response!


Riezell | Wyze Wizard

Off hand, it is very unlikely that the firmware update bricked the camera. If there was a problem with the current firmware, there would be lots of reports of it (there have not been). Have you attempted to manually upload firmware via the uSD card? If it’s a firmware issue or if the firmware upload got corrupted, that should fix it.

1 Like

Yes, I have tried all of that as well as spoken with Wyze support in efforts to fix the issue. Wyze is the ones stating that the firmware bricked it. Nevertheless, Wyze is not honoring their warranty.

What do you expect them to do - replace the camera with a camera that is no longer being built (and they don’t have anymore)? Giving you almost full credit on that camera to purchase an upgraded camera is fairly reasonable…


I expect them to either replace the camera or give me FULL ($30) credit for the defective one. Not half the price of the original device. Please READ the original post and get YOUR expectations in line. You do not promise a warranty if you are not prepared to honor it. Sounds to me like you work for Wyze.


Wow, all this complaining over $15.00


Since when was a V2 a $30 camera?


I believe they are listed on the Wyze website at $25.98 right now. So why are they listed if not in production?

1 Like

A) They are shown as out of stock in your screen capture. As far as I know, they were only available for a limited run in December of 2019 (when I bought three of them).
B) If you go to the Shop link here on the forum, they are NOT listed (which is where I had looked before). However, I did find that other Shop links on the site do still have the black V2 listed and show it as as out of stock. I wonder if they made a limited production run for black V2 cameras for the Wyze car? Pure speculation on my part (every Wyze photo I have seen for the car has a black V2)…

Not sure. I bought a pair not that long before they were listed as out of stock, one in April. If the two new ones die I’d expect Wyze to replace them.
I’m also more careful about which devices I will use for beta testing as Wyze states you are out of luck if it kills your device.

Um, they’ve been selling thousands of V2s to Walmart all month. They should honor this purchaser’s warranty in full, even if these are still disposable cameras.


They should either offer a replacement or full refund period. We as the customer should not let them do this to us. Yes it may be only $15 and not worth the trouble to some but to others it is a lot of money and more importantly. The principle of the matter. How is a company able to warrantee a product but in the same sentence tell you we dont make it anymore, so you cannot get it warranted. They should at least offer a full refund.


Wyze came back and gave me full credit towards a V3 cam. That is acceptable to me. You just have to stand your ground.


Good for you. Shame it had to be stressful.


Not to put too fine a point on it…Wyze should give you the camera for free. Here is the warranty statement:

All quality-related defects on products sold directly by Wyze Labs or authorized resellers are covered by a one-year limited warranty, beginning on the date of purchase. Defective products will be replaced with a new model, a refurbished model of equal value or, if both are unavailable, the model nearest to the original model’s form, functionality, and performance.


Apparently they are still being sold on Amazon as well. I just ordered a pair after they were out of stock. They are supposed to be here Saturday. Amazon just charged my credit card.

Update: Cameras arrived yesterday. I don’t expect any problems with them but I would expect Wyze to honor the one year warranty.

1 Like

Seems Wyze’s gotten so big they don’t really care about a customer. They’ve forgotten what the word “goodwill” means. Word’s gonna get out and what Wyze could have done by just sending a V3 to this unfortunate customer will wind up costing more than the dollar amount of Wyze’s cost of the camera plus the shipping cost.

Times have changed. A few years ago, I purchased a v2 and updating the firmware, it “bricked” my camera. At that time, Wyze has class and sent, no charge, a new V2 camera.

1 Like

Same issue happened to me. Won’t do anything except power up. I flashed it with the Webcam firmware and it became responsive again. I believe it can be flashed back to regular Cam mode from Webcam. You should likely see similar results

Same happened to me a while back, none of the trouble shooting I was provided with by Wyze has solved the issue. I was told the warranty has expired and was not offered any sort of credit. Seems like a common issue that needs to be solved by the company. My V2 would still be working if it wasn’t for the firmware update. I’m regretting on buying the smart vac from them now because if that goes to [Mod Edit] then it’s way more than a $30 loss.

MOD NOTE: Post edited to conform to the Community Guidelines.

Same happened to me a two weeks ago, none of the trouble shooting I was provided with by Wyze has solved the issue. Tried reflashing with SD card, still dead.
Need to test the firmware upgrades better.