Cam OG and saving video

Hi, I got my Cam OG today. It has some issues… it does not recognize my microSD card at 64GB. And when under events I am trying to download a recorded video from the cloud it suddenly crashes that events tab and goes back to the home tab within the app. No matter what I try just don’t works.

Photos though are possible to download.

Anyone else with this issue and Ca

Welcome to the Wyze User Community Forum @marculito! :raising_hand_man:

When the cam is on, and you insert the card, does it chime after a second or two?

Have you tried to open the SD Settings in the Advanced Settings to Manage microSD and format the card?

Have you tried a full format on a computer prior to inserting?

I just tested this and didn’t have any download failure. Since this is an app function and not related to the cam, is your app up to date? What version?

1 Like

I put in the microSD card when the camera was off. And yes tried to reformat it but it shows only 0 out of 0GB. Not showing up as 64GB.

Have not tried format it on a computer before. What format should it have? I am using a Mac.

Regarding saving videos I have an Android phone running version 2.38.1 (161).

Your Android app is up to date. The cam is compatible with both FAT32 and ExFAT formats so either one should work. I would suggest a full format, not a quick format.

1 Like

I have tried format the card on my computer and it still does not recognize it. I took another car and put it inside the camera, from one of my other brand cameras which have worked there but still same with that 32GB card also.

I tried updating to latest beta of the app, still can’t download videos or get the SD card running…

Something seems weird… i have ordered another card of Kingston brand also that arrives on Friday.

But yeah,…at least I would be able to download my videos from the cloud. I have a Cam plus subscription… funny it shows 0 hours video length and 0 people detected. Even though the camera have people detected under events.

Definately something not right.


  • Go to Account → App Settings and clear the cache
  • Sign Out
  • Force Close the app (from the OS App Info)
  • Reboot the phone
  • Reboot the cam with NO SD Card in it.
  • After the cam reboots, insert the SD and listen for the chime.
  • Open the app and test the event download

If the new SD card you ordered gives you the same no-read, you may have a cam with a defective card slot. If this turns out to be the case, definately reach out to Customer Support and request a Warranty Replacement.

1 Like

Tried all above, still the same… also tried installing the app on an older Android phone. Same thing there. When trying to download the video the app crashes.

Even though I have granted it access. I will try it from an iPhone also… and we’ll see what happens.


I have sent the case to support by email with log id etc. And the log from the beta version app.

When my old iphone is charged I will try the same things there.


Does the event video play in the events viewer or is there a green question mark on the right side of the timeline?

I open the video from the Events tab and then press the download symbol. But I think I figured out the problem! When disabling the audio in recordings the app crashes when you try to download them. Enabling audio in the recordings and suddenly I can download them. Must be a bug?

Since I can replicate this on two different Android phones now. Don’t know how it is with the iPhone app but at least this happens in Android…

1 Like

Definately sounds buggy. Since you are now on the Beta app, that needs reported with logs over in the Beta Release Thread for the App:

And now suddenly I can view recorded videos on the card under playback., even though when I go to manage the card it shows up as 0GB…

I have sent log files to them now also with all details of the issue.

1 Like

it should show 0GB/32GB, means it is an empty card.

Regarding not able to save video when “record sound” is disabled, I’ve logged the issue and will fix later.


I understand that, but it shows 0GB/0GB. So something is wrong there. Even though the card is inserted and formated.