Bulbs not turning on/off with rules

Has anyone else experienced issues with their bulbs suddenly not turning on or off with rules? It started a few weeks ago with one of two bedroom lamps not turning on as it should. Then it started to turn on (on schedule), but not be the right color or brightness. The porch light doesn’t turn on when scheduled. One of the living ramps doesn’t turn on at 100% despite the rule specifying so. Not sure what to do without resetting all of them and having to redo my rules.

Tried disabling airtime fairness per some troubleshooting articles.


If you look at the rules history in the app, what does it show? does it say the rules are successfully ran or failed? What is the firmware version on the bulbs in question?

Yeah the history says a rules ran successfully one example of my issue, this morning it said the rule ran successfully to turn on our living room lamp to 100% at 5:30am, but it’s dimmed all the way down to 1%.

I do have a nighttime setting that dims it down over the course of an hour before shutting off at midnight. And it’s like the bulbs are turning back on in their previous state rather than what the rule is stating.

I also checked the firmware on all the bulbs and everything is up to date (

1 Like

I’m following this because I’ve been experiencing the same issue with all my bulbs over the last few weeks.

Schedules/rules not turning on/off. Bulbs not turning brightness up/down according to rules.

Never experienced this issue until the latest update on the app.


And here I thought we needed to make sure the app was up to date to prevent these things :laughing:

I deleted all my rules and recreated them. But that hasn’t solved the issue. One of our bedroom lights turned on like it should with the night time schedule but the other one didn’t. Same with two living room lamps; one turned on and the other one didn’t. And our porch light hasn’t been turning on.

I was initially asked by support to delete all the affected bulbs and re-add them as new devices which I was really hoping to avoid, but this seems to be the only solution that may fix the issue. At least for a little while. I’ve had this issue before and had to delete them and re-add them, but here I am again :woman_shrugging:t2:


I’m having the same issue. My front porch bulbs are in a group. My bedroom lamp bulbs are also in their own group. Both groups have different rules controlling them. When both sets of lights are scheduled to come on, one bulb in each group will come on at 1% brightness, even though the schedule has them set for 50% brightness. I’ve deleted the rules and recreated them but that did not solve the issue. This problem started happening three weeks ago. I’m running the latest version of the app with the new rules engine and all bulbs are on the latest firmware version.


What app version? There are different app branches and each has their own “up to date”. It’s best to always state the branch and version number sequence for clarity. Examoke: Production 2.23.xx or Beta 2.23.xx. thanks in advance!

1 Like

I’m running the iOS production v2.23.23

| Omgitstony Forum Maven
August 16 |

  • | - |

What app version? There are different app branches and each has their own “up to date”. It’s best to always state the branch and version number sequence for clarity. Examoke: Production 2.23.xx or Beta 2.23.xx. thanks in advance!

iOS App V2.23.23
Wyze Bulbs Firmware

Me too - this seemed to start after the last app update for iOS. Rules history show the rule was successful but they are not. It is not consistently failing either - sometimes they follow the rule and sometimes they don’t. All bulb firmware is up to date. This is mainly happening on the original Wyze Bulb but this morning one of the Wyze Color bulbs also failed to respect a schedule rule.

I have also tried deleting the rules and adding back but that did not work.

@WyzeGwendolyn Here are the logs I submitted today:

App version: iOS 2.23.23 (production)
Wyze Bulb firmware
Wyze Color Bulb firmware


After further testing, it seems setting a rule to turn ON and additionally setting specific actions for brightness and color temp is what’s borked.

Reviewing rules history (which always says successful even when not successful) one of the secondary actions is firing before the ON action. E.g. the brightness fires prior to ON or the temperature fires prior to ON. I first tried deleting the entire rule and making sure the ON action was first in the list. That didn’t work. I then just deleted the brightness and temperature actions and just left the single action to turn ON and that worked in one test.

Would be interested to know if anyone else with this issue has those actions set and if removing them succeeds in turning the bulb on.


I’ll update my rules and give it a try with testing. Although I have bedtime routines that dim the bulbs to 1% over the course of an hour in the evenings. So if I change my rule to just have the bulb turn on, I suspect it’ll turn on at 1%. :thinking:

Funny enough I noticed that those additional configurations randomly showed up on the rules one day. When I first created my rules, those weren’t options. It was just simply on/off.


Yeah it’s weird. They were in the Ui somewhere when I first installed them last fall, but not where they are now. I feel like it was under a secondary menu before.

MAN I thought i was the only one. SO ANNOYED that they just stopped working a few weeks ago. and yes i see now it was after the last upgrade. honestly i think they should fix this. I have had ‘porch on’ and ‘porch off’ rules for front and back porch for months and months and with three actions - turn on, set brightness and set color. WHY did they BREAK this and didnt they TEST any of these things.
i deleted and redid the rules at least five times and finally gave up … SO VERY ANNOYING

I sure hope some one from WYZE is following this and gets it FIXED


Yup exactly that. On/Off works but you can’t also set temp and brightness. I suspect if you create a separate rule to run after the On rule it will work but we shouldn’t have to do that. It wasn’t broken before and now it is.

@WyzeGwendolyn @WyzeHongfei Has this issue been put on the dev slate ?

1 Like

Yes. The don’t work for me either. I was told that you have to create a separate rule for the turn on and for the turn off. They messed up big time.

1 Like

Same issue!!
My rule don’t work, if detect motion turn on light x and I’m rules appear executed successful but the lights don’t turn on, everything is worth the last firmware, the last version of app, but the rules don’t working as is supposed to do

1 Like

There was an update recently… the UI for the bulbs is totally different now. Going to rebuild my rules and see if anything improves.

1 Like

Now you have to create a rule for the turn on and a separate rule for the turn off or it will not work. Use turn on option for both and the set the action to turn on or off. It’s odd but it works.

I have been fighting with this as well…

My theory is this:

#1 - Only the regular smart bulbs are affected. Color Bulbs have no issues.
#2 - Older rules seemed to be most affected.
#3 - Motion Sensors trigger everything fine. Contact Sensors do not (V1 or V2).

I have:

#1 - Deleted the device, Deleted the rule, Deleted the cache, force-closed the app… Add everything back in. - No change in reliability.
#2 - I changed a bulb out with one I had in the drawer that was replaced by a Color Bulb… That seems to have helped tremendously. My theory is the rule is messed in the Wyze Database and you need to change the device (renaming it doesn’t help, probably based on MAC ID).

In my example, my laundry room has a simple rule… open door, turn on light. It has been so inconsistent.

Switching the bulb out seemed to fix it. I think their is a ghost in the shell for older rules/hardware. It’s like you have to scramble it up and then the Wyze Rule Engine sorts it out???


1 Like