Bulb Questions

Hi Everyone!!
I have 4 cameras (love them) and 4 bulbs (not working great) and I have a few questions about the bulbs.

Do the bulbs require Internet to operate? I.e.-is the schedule stored in the cloud or in each bulb? I’m having issues with one of three bulbs not always being connected. The bulbs are all within 10’ of each other and the 3 cameras. The cameras work awesome, the bulbs not so much. I get the Cloud Icon with a line through it. If the bulbs need access to the “cloud” to operate what port(s) do they communicate on?

Any help would be greatly appreciated.



The schedule is stored on the server, not on the bulb. Make sure your bulbs are not enclosed in metal fixtures. Metal will interrupt the WiFi signal.

Don’t know what port they use. You can use a tool like Wireshark to sniff your network and look for their Mac Address.


Welcome @jvandomselaar

I took this from a Wyze Twitter Post:
TCP : 80, 123, 443, 8443, 8605, 10001, 10002, and 22345. UDP : Minimum of 80 and 443. But we use UDP ports dynamically so we recommend you open all of them if possible.



Did you update the firmware? My bulbs were a monster to get set up initially, but once I did, I updated the firmware and they seem to work as intended now.

Nerdland, and all.
Firmware was upgraded the first time I turned them on.

I thought I had it narrowed down to when my kids were burning up the bandwidth, but nope, its out right now and no one is home. One of lights (not always the same one) looses comms with the cloud. OR so i think because it has the dreaded cloud with a slash through it. All 3 cameras and 2 other bulbs which are all withing 10’ or so of each other are working fine. The one bulb has been offline for about the last hour. I pull down on the screen to re-fresh on my phone but the one bulb is out. Any ideas anyone? I’ve tried pinging the bulb IP from my PC, but they must have that blocked as it doesn’t work even for the bulbs that are on line. When the bulbs ARE on line the wifi is a full three bars, Even when one bulb is offline the WIFI strength for the other two is a full three bars and oddly enough the bulb that is offline has three wifi bars too…but it may be old data because the bulb is offline…It seems to be more of a CLOUD connection issue than network/wifi issues on my end,

Any ideas of what to check/try would be greatly appreciated. Maybe I need to enter an official ticket to Wyze.


I’m not really sure. When I first set mine up, I had a couple that kept disconnecting like that, and I couldn’t get them to reconnect no matter what. I was moving them into lamps that were closer to the router, etc. So whatever was happening, it seems to have been losing the ABILITY to connect. I had to remove them a couple times and put them in pairing mode again. Like I said, it was a monster getting them connected in the first place. But after resetting the problem bulbs 3-4 times, I haven’t run into those issues again, and I can even move them from fixture to fixture and they seem to reconnect now.

When I set them up, I had to disable 5GHz wifi at the router level, because I couldn’t prevent my phone from automatically choosing that most of the time, and every time my phone reconnected to the 5G WiFi after disconnecting from the Bulb’s SSID, it would time out. It seems like a dumb issue, because you have to enter the WiFi network SSID and password, which are the same whether it connects to 2.4GHz or 5GHz. But alas, it was the only way I could successfully get them to connect.

I have a suspicion about the issue, but I wouldn’t put money on it. I noticed that when I disconnect the bulbs, they remain connected to the router for about 5-10 minutes. That means there’s obviously a small battery in the bulbs, and the bulb probably relies on this battery having SOME charge in order to maintain a connection and maybe even to maintain its setting/connection to the app/etc. Since two of them worked great and two were a giant pain, I suspect that the two giant-pain ones may have arrived with a mostly-depleted battery, which wasn’t able to charge fast enough while I was getting them set up. That would also explain why they’ve been fine since the nightmare of the first day. But it’s just a theory.

Is your disconnecting bulb new, or does it get turned off at the switch fairly often?

This isn’t based on anything I’ve seen Wyze say, but here’s what I might try, based on my theory (Which may not be correct, but seems to explain some of the mystery.)

First, I’d put it pairing mode to reset it, but don’t bother with the app yet. Just turn it off and back on again after you get the pairing mode blink, so that it shines solid for an hour or two. (I’m not sure if the light needs to be shining for the battery to recharge, but it seems like it potentially could help.)

THEN try to pair it again. If you had the same 2.4GHz/5GHz issues I had, you may need to do something to address that, either at your router, or just walking WAY far away from your router when pairing it. (But it may be tough to verify that your phone is on the 2.4GHz band unless you just force it at the router level.) It might still take a couple tries (it did for me) but with some luck, you’ll get it connected and – fingers crossed – maybe it’ll stay connected like mine finally have.

Yes, the bulbs require Internet to operate. Wyze keeps schedules there, which command the bulbs.

Bulbs not being connected are a separate issue. That’s usually either a local environment issue, or a malfunction.

@TheNerdCorner, is that a list of ports for the bulb, or the camera? I think that list is for the camera:

@nerdland, I don’t believe the bulbs have a battery in them. If the bulbs stay connected for 5-10 minutes, it is likely because of a polling increment, not a battery. As a for example, the sense sensors will hold a state for 4 hours because of a polling increment.

As far as what network the phone is on, it doesn’t matter. My phone has NEVER been on the 2.4 GHz network while setting up ANY Wyze product. As a test, a few times I have actually set up devices from OUTSIDE my network using the cellular network system. Yes, the device you are setting up still has to be locally available to the network you are setting it up for, but as long as you type the correct SSID and password into the setup info on your phone, you are good. This is why they ‘require’ that – many people don’t change the pre-filled info, so the setup bombs if they are not on the same network.

Walking away from the router to set them up can work in instances where there is a bad band steering implementation on your router. When the router tries to force the device to connect at 5GHz instead of 2.4 GHz, then walking away instead of turning off the 5 GHz can take you out of range of the 5 GHz and leave the 2.4 GHz as the only option. However, I’d go with switching off the 5 GHz band for setup if you can, which is the typical way to deal with that issue.

What do you mean exactly? Are you saying that my router doesn’t update the list of connected devices for 5-10 minutes after the bulb disconnects? That’s not accurate. When I turn WiFi off on my phone, for example, it disappears immediately. Same thing when I unplug any of my other internet-connected devices.

My experience is only anecdotal. I can’t say for sure that’s what’s causing it. But for me, that was the ONLY way I was able to get it to work. Wyze even tells you to turn off your cell phone data, for example. If it wasn’t basing it on your phone’s internet connection, I’m not sure why this would matter at all.

Hi everyone. I discovered something and seemed to have made some progress. I was noticing in my “attached devices” tab on my router login that the bad bulb IP had the WRONG MAC address for the bulb, and there was a second device that had NO IP but had the correct MAC. After reading Nerdlands replies about the 5GHz issues I went looking for my 5GHz setup info. I knew I had a differnet SSID for my 5GHz wifi so I wasnt to concerned about it being an issue becasue I had logged ALL my cams and bulbs into the 2.4GHz wifi…so just for fun i turned off the 5Ghz wifi and then re-freshed the Attached Devices and low and behold the weird connections disappered…I restarted my phone app and all my lights were connected and all my Schedules worked last night and this morning. So it looks like having the 5GHz wifi just running is a bad thing. I have my fingers crossed the rest of the weekend goes well…I’ll update this Monday and let everyone know.

Thanks for the input. I love forums, Really proves the power of many…3 think like 5…Cool!!!

Have a great Saturday everyone!!!

1 Like

No, not talking about your router. Just proposing there may be a delay before the Wyze servers poll the bulb and show it offline. 5-10 minutes seems excessive to me, but I have not done any testing in this area. I just don’t believe there is a battery in the bulb, and I know other Wyze devices have polling increments as long as 4 hours (the sense sensors).

Yes, although they do that for a different reason. Some phones will switch to cell data if they don’t detect an Internet connection on the bulb network. That makes it tough to set the bulbs up, so they have you turn off cell data to keep the phone from switching networks away from the bulb.

Sure. I’m not talking about the Wyze app. I was looking at the connected devices on my router. My router continues to show that the bulbs are connected to it, several minutes after the bulbs are disconnected from power. None of my other internet-connected devices behave this way when they’re cut from power. (The router shows them disconnected immediately after there’s no power) Therefore, I assume there MUST be a battery inside. I can’t really see any other possibility.


I may have been misinformed about those ports being for “wyze products” and not specific to the device itself.

Edit: After doing a port scan on my current plugs, it does appear to have a truth to it. But it may not be all the same across the board.

Apologies, I must have skipped right over the word router. Can you try your router disconnect test again? I just tried that test with all 4 of my bulbs, and they all disappeared from the router list within a few seconds (some took 2 router list refreshes, but doubt that was because the bulb was still there).

Okay. So I tried again and I think you may be right. When I turn off WiFi on my phone or laptop, it disconnects immediately. That’s what made me think there must be a small battery. But most of my other internet-connected devices exhibit similar behavior when I cut power – they still appear in the connected devices list on the router for a while. So I guess my phone and laptop must send the router a “disconnecting” signal or something, so that they disappear immediately. When a device disappears without sending the signal, the router probably continues to show it in the list for a few minutes while it pings the device before it gives up.

1 Like