Beta firmware roll back

I have been on the Beta test program for a while [both android app & firmware on devices] and happily update / test the latest releases. It is fun to be a part of the progress but there seems to be a lack of support when there are issues. Recently there seems to be some problems and as a result of updating to the beta firmware both my robot vacuum & my home hub have bricked themselves. Contacting support has been a painful process, often having to explain multiple times that I have already tried all the listed troubleshooting steps on the support site, often being pushed off chat to email support that goes round & round in circles.

I guess I have two main questions:
1] Is there a way to manually load firmware to these devices like I can on a camera?

  • If so, why is this not on the support pages?
  • If not, why not?
    2] Is there a better way to get through to support that are more knowledgeable especially when it comes to the Beta stuff, or at least a way to report issues with Beta firmware to the devs?

I am an IT pro by trade & completely happy digging into the depths of an issue, flashing firmware & getting my hands dirty. I feel let down by a company that I put my trust in, I was going to install the wyze lock this weekend but I just don’t trust it to not break at this point.


As a slight aside, it would also be really nice to see release notes on the beta firmware from within the app, the same as you can for full release notes. I know they can be found elsewhere but that is a lot of hassle & kind of goes against the ease of use that would be one of Wyze’s main value points.


Welcome to the community. Sorry to hear of the issues with your devices.

Unfortunately I don’t believe there is an easy DIY way to flash the firmware to either of these devices. This is mostly because they don’t have an easy access removable SD card like the cameras do. I assume this is because there is no other reason to have one (they don’t store videos or anything like that and have sufficient onboard memory), so it would be an extra cost for something that is probably seen as a [hopefully] rare use case.

I also once had an issue with a beta firmware on my hub, though I was fortunate to get it to work again eventually.

I know the above aren’t ideal answers…and they are my personal opinions. I don’t represent Wyze in any official capacity. I too, am a customer, albeit one that loves to study and read up and keep up with all the testing and product knowledge.

Honestly, I prefer the support by email. It allows me to do things at my leisure. They will of course repeat all the standard troubleshooting and go through a few different back and forth responses, but after enough times telling them what they advised did not work, and having exhausted the script, things have always gotten resolved for me. I acknowledge it can be frustrating and time consuming…which is partially why I like the email contact the most, I can do things in cracks of time or at my leisure, and as mentioned in the original post, sometimes they eventually push for it to go to email anyway to continue the next level of escalation…so I usually like to just start there.

Since you’ve indicated you’ve gone through all the troubleshooting and such with support, I won’t repeat a bunch of it here.

I would like to ask though, what firmware version do you have on them (or tried to upgrade to) that ended up making them unresponsive? Sometimes we can post about it in the thread discussion about that Beta version release and get some direct help from the people overseeing that particular release. It might be good report it there regardless.

Thanks for your input. I guess I forgot to mention that in the OP but even though neither device have an SD card, they both have a USB port. I have not plugged either into my my machine yet, but I have used USB connectivity to flash firmware to [non Wyze] devices in the past so in theory it should be possible.

I checked the Device Info on the app, it shows that the Vacuum is on FW: 1.6.130 but it never came back online after that update.

The hub is on FW: and shows as online in the app. After the update to that version, whenever I try and switch modes within the monitoring section of the app or on the keypads, it fails to change mode.

1 Like

I didn’t find a thread with info about that WRVacuum firmware version.

Here is the thread where they released that Firmware version for the Hub:

There weren’t any other reports about the hub having problems so it could be useful if you are willing to report there that your hub had issues after updating to that firmware version. We might be able to see if anyone else can replicate that or narrow it down in some way.

I didn’t even think about the USB port being used to flash other devices like these. Thanks for mentioning it. That is a good idea. If you create a Wishlist post asking Wyze to start allowing us to flash firmware into other devices like these through the USB port, I will vote for it too.

A few weeks ago there was a beta firmware update that unfortunately bricked a number of Wyze robot vacuums. Mine included, sadly. If you look back in forums both on Facebook and here then you’ll find they stopped that beta firmware for a short time while they investigated. I ended up having to get a replacement. I had slow white pulsing silent lights that didn’t respond to any amount of attempts to wake back up. There is a USB port but we do not have the access to to flash this via computer in my understanding. I googled extensively looking for solutions and although Reddit had an old thread - I don’t have the IT knowhow for it (I’m a nurse lol) Contact support as they will definitely help you … just takes a bit of jumping through required hoops…. I’ve learned that being part of beta testing also includes a bit of risk with the reward! I looked back on the last firmware of the failed beta 1.6.130 and it was the same as you mentioned. The current firmware is now 1.6.173 on my replacement vacuum.

That’s great info, thanks. Also, thanks for being a nurse, y’all are awesome in my book!

I had the exact same symptoms as you, glad that they caught it before too many issues were caused! Do you by chance have any of those links handy, either to people talking about that failure or the reddit thread? I know support are good at taking care of warranty issues, I just don’t like admitting defeat on such things, which is why I enjoy being a Beta tester :smiley:

1 Like

I’m thinking the above will get you to the beta forum link I had been following. As for Reddit - if you follow r/wyzecam and then search bricked vacuum then you will see some of the past discussions about this.

The PM did request to have the bricked vacs shipped back (and I tried) but both times with customer service - they told me to keep/dispose of.

If you follow in Wyze beta testers group on Facebook then around 8/18/21 is when that beta release came out and the subsequent issues/comments for some.

Hope that helps a little. I tend to jump around on all 3 sites but had only bookmarked the one link. Best of luck!

1 Like

Hi @jlreese, do you still have the customer support ticket number that the agent told you to keep/dispose of the bricked vacs? Thank you!


Yes! The last email correspondence was was dated 8/27 and was ticket 1422643.

1 Like

OMG, do I wish there was a rollback in any app so we didn’t need to bother anyone. What a pain for everyone involved otherwise!

My Robot Vac also got bricked with that update last month. After waiting a few days and following the Facebook FW update thread, I just called CS and let them know that it was the firmware update that killed my robot and the troubleshooting steps I had already completed. The CS rep understood and went straight into the replacement process.

At first I was told to keep/dispose, but I mentioned that @WyzeHongfei said they wanted the unit back for analysis. I was then sent the RMA return label.

After a few days, I updated the vacuum to FW version 1.6.173 with no issues and it has been solid ever since.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.