Base station won't connect to Eero

I can’t get my base station to connect to my Eero network. The light just keeps flashing blue, even after repeated reboots + ethernet cable swaps. It’s plugged into a secondary Eero (not the main one plugged into the router). Can anyone help me sort this out? Thank you!

Welcome to the forums! Does it work if you plug the base station into the router itself? Trying to trouble shoot if it’s a eero setting that’s causing issue here, or a router issue.

I don’t have a eero mesh system, but Ill throw out the bat signal and wonder if any of my @Mavens friends do. Any Eero maves provide any tips here?


Hi @oliver_libaw and Welcome, again.
Read over what was available on the Eero and could’t find anything preventing setup.

The 2.4 Ghz and 5Ghz default to same the SSID but not sure if they are on the same sub-net as the Eero’s physical port connection on satellite station.
To set up your phone WiFi and Base unit must be on the same network. Shut off your mobile data connection.

There are optional protection packages for data security on the Eero. Check that the proper ports are open on the router so the Base can communicate with the AWS & NTP servers.
1st time hookup: Closed everything on my network and opened the firewall. Got it working, then allowed the necessary ports on router.


No Eero here. @dr.know and @Omgitstony have some great tips!


Welcome to the Community @oliver_libaw
I also have an Eero and have had absolutely zero problems with any device connecting. There is an option to pause 5g temporarily while you try to connect:
Home Screen/Settings/Troubleshoot/My Device Won’t Connect/Pause 5g Temporarily.
Strongly doubt that’s your problem though, since you are direct connecting.
Obvious suggestions are switching ports on the back of the Node you are using or swapping to a different cable (which you have already tried). In particular I would try using your Gateway Eero but even just swapping nodes might help if you have more than just two.
If none of that works I would try contacting
Wyze Support:
Live support is available: +1-206-339-9646 Monday - Friday 5 am - 6 pm PT Saturday 8 am - 4 pm PT. This should give you a quick resolution, but you can also reach them online at Wyze Support.
Also, I have found that the Eero Support is excellent if it turns out to be an Eero problem.


After a thorough and exhaustive investigation, I discovered…

my ethernet cable was balky. I swapped it out and it’s working fine now : )

thanks so much for the quick, helpful response!


I’m glad you are up and running. I have loved mine. I struggled for a year with an ISP box and had endless problems and many calls to Support, all of which stopped when I moved up to Mesh.
Feel free to post back with any other questions!


I had the same problem. It turned out to be the WPA3 security setting on the eero. As soon as I turned it off, I was able to connect to the eero mesh network. I hope this is helpful to others as why support was unable to solve the problem.


I was able to connect my base station to eero router with the ethernet cable but unplugging it to connect to Wi-Fi failed every time. Turning of the WPA3 fixed the issue for me too. Connected to wifi right away.

1 Like

I have Eero pods, and WPA3 enabled, and every single device (50+) are able to figure out whether they want to connect to WPA2 or WPA3. The Wyze Base Station is the only device that has no idea what to do. With WPA3 disabled, it figures out how to use WPA2. With WPA3 enabled, it just flashes blue.

I have 8 WyzeCams (4 indoor and 4 outdoor), and this is fairly unacceptable as a workaround. WPA3 has been around for at least 4 years. Surely Wyze Labs can just make the Base Station smart enough to continue to use WPA2, and not just give up and do nothing.

Welcome to the forums! I have experienced something very similar to your issue with the wifi settings on my AP and the base station connecting to it.

I am using Eero 6+ pods. The only option I have is to disable WPA3, which seems like a non option. WPA2 is still available to connect with, the base station just wont do it.

I think you are right. BTW, I found EERO’s Customer service very helpful in working through the problem. Wyze Customer service not so much.

I don’t suspect it’s a big problem to fix, since all my other devices just choose to use WPA2 if they don’t support WPA3, and both are available. Feels like the Wyze Base Station just makes a wrong decision somewhere along the way. It seems like driving a tack in with a hammer to disable WPA3 for everyone, just to appease one modern piece of hardware.