App thinks garage door is closed when it's open

I’ve had the garage door controller for around a year. It’s worked great. I created a rule to automatically close the garage door at 9pm if it isn’t already. That worked fine until the last 5 nights or so. With the door open, the app says “garage door is closed.” So of course the 9pm close rule doesn’t trigger because Wyze thinks the door is already closed.
What’s crazy is, I haven’t changed anything. The QR code is still mounted on the door and when the door is actually closed and I look at the cam, the QR code gets a red outline around it. I re-calibrated the camera to the QR code, just to make sure.

When the garage door is opened, I get a notification in the app stating the door has opened, and it records an event. At some point after opening the door, the app changes to say the door is closed even though it’s not. No event is generated when the app changes to thinking the door is closed. If I manually close the garage door (either using the button on the wall or the button in the app) then an event is generated saying “garage close.” So the problem is fairly narrow - the app somehow thinks the door is closed and therefore won’t trigger the rule to close the door at 9am.

As I said, this is a new issue as of the last few days. How do we solve this?

This is just a guess, but have you tried to delete the rule and recreate a new one to assure it’s not a ‘rule is confused’ issue? As I’ve seen strange things happen with app cache, I’d also try clearing the app cache then see how it then operates.

I don’t think the rule is confused because it’s the app itself that thinks the door is closed. Here’s a screenshot.

If I look in garage door events I can see sometimes it does generate a “closed” event Even though the door wasn’t closed. I’ll try out your app cache clear idea. I also power cycled it to see if that would change things.

Power cycling the camera did seem to help for a day or two…but ultimately it’s still not working right. Nearly every day it thinks the door has closed a short time after opening, even though it remains open. Someone from Wyze support- what do I do to solve this? It worked for around a year just fine.