App "Eject SD card" button

First Post, please be kind
I have a Wyze Pan Cam in another house I own about 5 states away.
Recently, the Cam is telling me “SD card is not available”. (When I first set it up it worked fine.)
I have tried rebooting (Remotly) the Cam and this appears to work, but the SD card continues to be unavailable.

What does the “Eject SD card” button do from within the App? Can I use this button to reformat the SD card?

Or am I going to have to make the long drive?

Thank You for reading this


If there is an SD card detected in the camera, there is an option in the settings to reformat it. However, in this case, the camera is telling you that it is not detecting an SD card. In this case, if remote restart didn’t solve it, I’m afraid the only option is to physically power cycle the camera and remove and reinsert the SD card.

The cameras are generally very reliable, but sometimes glitches require them to be power cycled. For this reason, it’s a good idea for cameras that are inaccessible or far away to power them through a smart plug so that they can be power cycled remotely.


I would add that for some of us the SD card support is an Achilles Heel on these cameras and just does not work reliably. I suggest you look into Wyze’s optional Continuous Motion Capture service or look elsewhere if you require reliable recordings longer than the 12 second cloud clips with 5 minute waiting periods…

1 Like

Agreed. My cams have eaten countless SD cards. Sometimes reformatting from a PC will fix the issue, sometimes the cards are just dead. CMC is okay but I still end up missing chunks of video, a 1 minute before/after “buffer” is desperately needed. 100% sensitivity still sometimes misses obvious “movement” that the green box tracking doesn’t pick up, ending the CMC recording. Stupid that I’m paying for a subscription, but still end up needing to go back to the SD to view footage, just to realize the camera suddenly doesn’t recognize the card. At very least, I need an alert that my footage is no longer being recorded.


I have one camera that I put an older 16GB card in since I was out of 32GBs at the time (more were on order). The card later dropped offline as mounted in the camera and the remote restart function will just show a FAIL when attempted. All other functions of the camera work fine. Latest release firmware installed. It’s at a remote site so will power cycle next time I am there. It was a Class 10 card.