Another Software Issue?

Now whenever I get a motion notification and I open the Wyze app it goes right to live view on one of my cameras. It never used to do this and I don’t like it. I just want it to open up the the Home Screen like it used to. What the heck Wyze?!

Not a software issue, it’s functioning as intended. This isn’t new, it has been discussed for years now, including in an AMA some time ago, The way it works is like this:

If a notification comes up and you press it while the motion event is still ongoing, then it will first send you to the live stream because the event isn’t done yet, it is still happening now and you might want to do something like set off the siren or talk to whoever is there. BUT if you wait long enough and click on the notification and the event is already completed, then it will send you to the events tab [Recorded event] instead because there is no active event and no reason to trigger the siren or talk to anyone because the event is over with.

If you do this with a camera on the older UI, then you can click the events tab and see what happened since the beginning of the event. If you do it on a camera with the newer UI, you can click the event below the live stream and scroll backward to the befinnint of the event. Otherwise, you can wait until the event is completed and then click the notification and it will load the cloud event instead of the live stream. To my knowledge, it’s worked like this for several years now on almost all the camera models, it’s not new. We get people asking about it every few months.

1 Like

Pretty sure I wasn’t pressing the notification while the event wasn’t done. But it’s possible I had been. Maybe haven’t noticed this before because I normally don’t press the notification while the camera is still recording an event. Or maybe my phone is too small and I can’t see what I’m doing anymore. :slight_smile:

1 Like

No worries my longtime forum colleague. :slight_smile:

I know you are generally a VERY detail-oriented person. You have many times shared things that are overlooked by many people or often one of the first people to notice something early on. It can be helpful for us to try to get things reported in the early stages before something affects other people.

If you happen to notice that it ALWAYS opens to the live stream, even after the events are definitely ended (ie: 5+ minutes after the notification arrives), let us know. It should only send people to the live stream if the event is still ongoing and never if the event is definitely over with. If you notice it working differently we’d certainly love to report it. :+1:

1 Like

Just had another notification and I waited 7 minutes before pressing it. Took me right to the recorded event and started playing it. Didn’t take me to the events tab. Something is off for it to do this.

1 Like

Thanks for checking. :+1:

Just to clarify, you’re saying it will pull up and play the recorded event for you as expected, but just not in the events tab? I haven’t paid close attention to this, but that might be normal as long as it is at least playing the event. :thinking: I’ll try to pay attention the next time I get a V3 event…

Are you running the new 2.50 app on iOS?

I assume you are using firmware which was last released on 1/16/24? I think you usually avoid beta firmware if I remember correctly, so I’m assuming that’s the one you’re on right now, correct?

You said if I press the notification when it’s done recording that it would take me to the events page. It didn’t, it took me right the recording and starting playing it. So that is what it is supposed to be doing? Maybe it is but I just can’t remember because normally I delete the notifications and just open the app directly, then go to the Events page to open and view it. I do it this way because for some reason the notifications don’t always get deleted after viewing the event. And yes the app is 2.50 on my iPhone and the V3 camera is on the latest firmware

You are correct, I guess technically misspoke and said the “events tab” when I meant the recorded cloud event. In my mind, I consider all cloud events to be part of the “events tab” since that is where all the cloud stuff is and the cloud events are part of that (ie: as opposed to the live stream which I think of as an extension of the home tab), but I just verified by using some older app versions and phones that it technically has always just loaded the event recording without actually loading into the events tab. Thank you for correcting me. :slight_smile:

I just updated the original comment to strike out “Event tab” and insert “Recorded event” for better clarification. I notice I did say it correctly in the last paragraph, just misspoke in the second one.

1 Like

Thanks for checking into it, I appreciate that.

1 Like

So over the last day I have been extremely careful with the notifications and app. It’s definitely going to the recorded video when I open the app, which it isn’t supposed to do. If the recording is around 30 minutes old then it doesn’t do this, but sometimes even when it’s less time. Seems to be all over the place. And if I open the app I do not want to go straight to a recorded clip, which it starts playing. I prefer to pick which clips I want to look at first.

Another issue is when I set an event recording for Smart Detection to label Person and Pet, I often get events labeled as Vehicle (when a vehicle is in the frame). It’s supposed to only label what I checked, Person and Pet.

Oh and I still have the app freezing issue.

I did hear that Wyze was working on trying to improve the iOS app freezing issues. I have heard that it mostly happens to people who have a lot of devices, but it didn’t use to do this a while ago, so hopefully they can figure it out. That would be frustrating, and particularly with it happening to their users who have bought a ton of stuff from them.

That is interesting that you have cams labeling vehicle when you have vehicle tagging turned off. I had something similar with my V3 baby cam recently. It kept turning on face detection even though I turned it off. Was this a V3 that was doing this to you too? I’ve been thinking this might’ve been an isolated incident until I saw your post now. That makes 2 of us that had a detection getting labeled even when we had it turned off. I was waiting to hear if someone else noticed something like this too. I think I got it to stop just 1-2 days ago by upgrading to the beta firmware, so I think there is a fix on the way for this already. I’ll keep an eye out for more occurrences of this or others reporting it, but I can confirm that I saw something similar recently too. Let me know if you see more of this kind of behavior and whether you can get it to stop by toggling vehicle detection on and back off again.

I have an iPhone, MacBook Pro and an iPad, but rarely view my cameras through anything but my iPhone.

I am only using V3 cameras. Not only did a camera label a vehicle when it shouldn’t even though a vehicle was in the frame, another camera has done the same thing when there wasn’t even a vehicle in the frame and vehicle labeling was off.

But yes it gets very frustrating when things that had worked fine, then updates create new issues. This is why I wish Wyze would stop adding new features and just fix current bugs. Make it bullet proof then slowly add features. I wish they would bring back the sensitivity the cameras used to have a few years ago, because mine miss so much many events that are farther away in distance, that they used to be able to record.

Had a few more events and opened the Wyze app directly and it went straight to the event video again and not the home page. The recorded video had been finished 5 to 10 minutes earlier so it shouldn’t be bringing me right to the video. Definitely something is wrong and this is with 2.50.1.

Unfortunately, it actually doesn’t matter how long ago the event was, if we click on the event notification, it pulls up the app and the app checks whether the even is ongoing or completed. If ongoing, then it loads the liveview. If the event is completed, it will load the event video.

It doesn’t matter if the event ended 1 second ago or 1 day ago. The notification comes with an embedded link that sends us to that event.

I know a little bit about this since I have a different app (Home Assistant) that actually lets me custom-create my own notifications to link me to specific areas in my app. I will set it up so that when a certain thing happens (rule trigger from a Wyze device for example), I have it send me a notification, and in that notification I tell it when I click on the notification I want it to pull up this exact thing in my app…maybe a certain dashboard or other things.

In this case, Wyze has the camera notifications set up with a link/URL that tells us whether to go to the Liveview or the event recording. There are some other notifications that will take us to different parts of the Wyze App, but the Camera event notifications will always take us to the event it was notifying about (either a live view of that event, or the past recording of that event). Wyze, and most companies, don’t give us the option to choose where we want different notifications to link us to when we click them, so those are stuck and unchangeable.

But I think it would be really cool if we could customize our notification preferences this way.

Well, this is really odd because it was not doing this just a week ago, and only started happening the day I posted here about it. I can have 30 or more recorded events and all I want to do is go to the events page so I can decide what I want to view first so I can delete or keep them. I don’t like that basically Wyze is deciding what I watch first. It makes for another step I have to do just to get to the events page, which seems unnecessary.

Today I had around 50 recorded events from my V3 cameras. And again had numerous Vehicle labeling on some of them, when the smart detection event has vehicles off.

Also, had numerous times opening the app it didn’t take me right to the event recordings. And other times it did. The software doesn’t seem to be doing what it’s supposed to be doing. Doesn’t seem to matter if I restart the app or reboot my phone.

Well, opening the app when I get a notification definitely isn’t consistent going right to the recording or live view, it often will just go to the app Events page, like it used to do. Another thing I’ve noticed is that when it does go to the recording or Live View, it doesn’t show either and has Unknown Device at the top.

I’m so frustrated with Wyze software because it seems like with every new update it screws something else up.

I’m not liking how the app after opening it goes right to Live or a recorded video. Because I’ve noticed that the first video it tells me what camera it was but then I might have 20 more recordings and it says Unknown Device for all of them and they won’t play. So I have to close all of them down and go to the Events page, like I used to before the app did this showed live or recorded events after opening. So what good is the feature? Let me decide what I want to view! And most often by the time the live view opens up, the event is over. So I don’t need that feature either when opening the app.

Oh and the app freezing is getting more and more annoying. It happens every time I use the app to review recorded events.

Also had a weird issue the other day, 4 of my 10 cameras (in key locations), showed they were disconnected. Normally the only way to get them back is to unplug them and plug them back in, restarting them in the app doesn’t work when they show as disconnected. I have a smart plug on one camera and shouldn’t have have them on all the cameras. Plus, one of my cameras is the Wyze Flood light, so there is nothing I could do except cycle the wall switch. And this is something I couldn’t do if I weren’t home. Now luckily all the camera’s came back online by themselves, but if they hadn’t and I was away on vacation this would be stressful. I’d be thinking someone broke in and disabled the cameras.

1 Like

If it was last night, there was an outage/service advisory for a couple of hours.

Yes, it was last night. But seriously yet another outage and odd that it only messed with 4 of my cameras. The industry really needs to make outages not happen, if we are to rely on internet based tech for safety. Smart devices, smart homes, smart cars, become pointless if nothing can connect to the internet and fail to function correctly.