Android App Connectivity Issue

I am having trouble connecting to the wifi in my building with the android app. Our network is a guest network and there is no password, but my android app is requiring me to enter a password to connect. My coworkers all have apple devices and do not have to enter the password, it automatically connects. Any advice would be helpful! Thanks!

Just to clarify… the app doesn’t connect to wifi. It connects to the internet using whatever internet connection your phone has. You phone should be able to connect to that wifi. If you are not able to get your phone connected to the wifi, then that’s a phone problem, not a Wyze app problem.

On the other hand, if you are talking about getting the camera connected to the wifi, then know that there was a change implemented that no longer allows new camera setups to connect to a open wifi. This was done for security purposes. If you have coworkers that have cameras connected to that wifi, they probably did so before the new policy was implemented. Cameras connected before this change remain connected. But any camera that is newly setup (or re-setup) will not be able to connect to a open wifi.

Here is a workaround that will let you connect (with a small hardware cost): You can use a travel router as an intermediary device that will connect to your unsecured home network and bridge that over to a secure network accessible by the Wyze Cams. Complete instructions for that are here:

Finally, there is a #roadmap topic about this asking Wyze to reconsider (link below). You can hop over there and vote for it. Be sure to click the VOTE button at the top.


Loki - thank you for your response. My phone is connected to the wifi in my building, so that’s not the problem. Also, we all tried connecting our new cameras and devices on the same day. Their cameras weren’t “grandfathered in” before the security change you’re talking about. The app on apple devices automatically connected, but the android app required a password that does not exist on the guest network.

All I can think is that you happened to catch the timing such that your Android app was updated but theirs wasn’t. There are two ways this might happen:

  1. The iOS apps typically are released a few days after the comparable Android version due to Apple’s review cycle, or

  2. The iOS user doesn’t have auto app update enabled on their phone and didn’t manually update their app.

Can you say which versions of each app you were using at the time?

We had all three just downloaded the app at the same time. We just purchased 3 cameras and all downloaded the app last week together on the same day, 2 of us on apple devices and me using the Samsung Note. Theirs worked and mine did not. Then, today another coworker with a different apple device downloaded the app and his allowed him to connect as well. I appreciate your help in trying to explain why this is happening. I am hopeful someone will follow up with me in the next few days through the email question I submitted.

1 Like


Okay, I got the answer. Good news and bad news. The new “no open wifi” policy made it into the Android 2.0.x app, but won’t make it into the iOS version until 2.1.x which is currently in beta.

The good news is that if you can get the camera set up now using an iOS phone, it will stay set up as long as it’s not removed from the account or app. You can do this:

  1. Borrow one of your coworker’s iPhones.
  2. Log them out of the Wyze app and log into it using your account.
  3. Set up your camera using their phone.
  4. Log the Wyze app on their phone out of your account and back into theirs.
  5. Log into the Wyze app on your Android phone.
  6. You will now have access to the camera on your phone.

This works because all of the camera registration and settings goes with the account, not the phone.

Keep in mind that this will only work until the Wyze iOS app is updated to 2.1.x at which time no more setting up cameras on open wifi. You would then have to use the hardware workaround I described above.