Allow setup of Wyze Cam v3 Pro on open (unsecured, no-password) networks

This would be amazing if I could use this feature for Wyze V3 Pro in order to use them for research on university networks. :slight_smile:

[Mod Edit]: Title and tags modified to enhance search clarity.

I’ll run a test to confirm this feature is missing for v3 Pro once I dig through the junk pile to find an old router that allows an open network. :grin: In the meantime… please VOTE for your own wishlist topic.

1 Like

See also

It may just be app version, and not camera, dependent.

1 Like

My app is up to date (2.37.2). This is also an ability in the Wyze v3 cams, but not the Wyze v3 Pro… The issue isn’t necessarily an unsecured wireless network (or at least, the network isn’t public) - rather, at universities we register our MAC addresses and the network recognizes the address, and so no password is actually used - for Wyze v3, I just skip the password entering portion and it works fine. This is how many universities are set up, and Wyze is beginning to enter the stage of a high power science tool due to their low power usage and humidity/heat tolerance to be ideal animal behavior monitors. So Wyze could potentially profit by making these adaptations for researchers.

1 Like

It may be that Wyze just forgot that they implemented Allow Unsecure (no password) WiFi Networks while developing v3 Pro. I ran through the Wyze products last June and found the following lighting products cannot be setup on open networks and created this topic: Allow setup of Wyze lighting products on open (unsecured, no-password) networks

  • Bulb v1
  • Bulb White
  • Bulb Color
  • Light Strip
  • Light Strip Pro

I was able to set up all other products over an open network. Cam v3 Pro didn’t exist when I ran the test. I’ll do the v3 Pro open network test under various flavors of iOS and Android.


Cool, I just added my vote there. Only up to 5! (Though my semi-secret theory is that wishlist voting here is entirely meaningless.)


Forgot to follow up with results of my testing (Thank you for the reminder @SlabSlayer!):

This wishlist topic is a valid request. Attempts to setup Cam v3 Pro fail on open networks. App goes through the motions of attempting to set up, reads the QR code, setup fails and cam announces, “Cannot connect to local network.” Screen times out and asks you to reenter password even though you never entered one. Looks like Wyze forgot that they implemented Allow Unsecure (no password) WiFi Networks while developing v3 Pro.


How hard would this be to implement?

It sounds like a very simple bypass in code, as is currently done for all other cam types on open networks. But I don’t work for Wyze so I can’t really say for sure.

Wyze cameras on open wifi network

I live in the country and have an outdoor WiFi access point. We have no close neighbors and the network does NOT have as WiFI password. It’s used for a LOT of outdoor equipment so having a WiFI password does not work well. Wyze cameras once worked fine on this network. Now, I cannot connect new cameras to this network. I have other means to provide security and would like the ability to configure Wyze devices to work on this network without using a password.

1 Like

I have the exact same issue. I tried connecting wyze cam pro 3 cameras and spent hours on this and returned the cameras. I have no wifi password either. I asked support if the new cameras work on networks with no password and was told yes.

I did not get a refund only store credit. The about 2 months later I bought Wyze Pan Cam v3 cameras and after trying everything to get the to connect to my wifi out of desparation I put on temporary password on my wifi and then and only then could I connect the wyze cam pan 3 to my wifi. Once I removed the password on my wifi I the wyze cameras no longer connect to my network

I opened a support case and asked them to fix this and that I am willing to test. Here is my support case info

Hi, please report to your engineers that there is a serious bug in all wyze v3 cameras. I had returned 2 wyze cam pro 3 prior because they would not connect to my network and these 2 brand new wyze cam pan v3 would not connect either. I spent 4 hours on this and figured out that wyze v3 cameras will not connect during setup if there is no wifi password. I had to turn create a wifi password and then and only then would it connect.
Prior to this I factory reset cameras, deleted wyze app, disabled 5 Ghz network, and many other things

ticket # 3152783 and Ticket 2936080