All WYZE products stopped connecting

I stepped out today while my wife was home working, thankful for that, and was only out for about 45 minutes. In the time that I was gone all my WYZE devices stopped connecting to the WiFi. All our other non WYZE devices are working properly. I’ve tried deleting and reinstalling one of the four cameras I have and it doesn’t connect, including the front door lock. Any suggestions or help would be appreciated, FYI I cannot restart the WiFi at this as my wife is working.

Are you sure it’s not just the app on your phone? Can you reach the cameras from another device with the Wyze app?

I’ve tried both my phone and my wife’s. I’ve even tried reinstalling one of the cameras and it doesn’t connect to the network. I receive error code 90 when looking at the feed.

Once my wife was done with working, we completely turned off our WiFi for about 15 minutes, and we were able to reconnect everything when we turned it back on. I just don’t understand why it was only our WYZE devices that weren’t working and nothing else. It seems like it’s a weekly issue that one WYZE product or the other has issues. I use to rave about these items and now I’m not so sure anymore.