Alexa unable to show Wyze cam view

When I try to use the “Alexa, show [cam name]” command, starting in the last 2 days, Alexa says, “Sorry, [cam name] is not responding. Please check its network connection and power supply.” But I know the cam is working, and I can access it fine using the Wyze app. Is there an issue with Alexa integration? The Wyze skill remains enabled in my Alexa settings.

I just tested a WCO, v2, v3, Pan Cam v1&v2, VDBP, and all came up on my Alexa show/fire devices.

Have you tried disabling and re-enabling the Wyze skill in Alexa?


I am now having the same issue on my two V3 cams with CamPlus. No issue with my three V2 cams or my PanCam, none of which have CamPlus. I removed one of the V3 cams from Alexa, then added it back again, but it still cannot connect via Alexa. No problem connecting in the Wyze app.

Don’t remove and re-add them. Simply disable and re-enable the Wyze skill.

Thank you for the suggestion, but that did not resolve the issue for me, either. Still the same situation as before disabling and then re-enabling the Wyze skill.

Disabling and re-enabling the Wyze skill in the Alexa app did not work for me either. I cannot view the Wyze cams using any Alexa app, the Devices dashboard on my Fire Tablet, or on any of my Echo Shows :frowning:

I’ve also made sure the cam firmware, Alexa apps, Echo Show software etc. is all up to date.
It must be some incompatibility between versions?