Alexa and V3 Wyze Cam

I have several Wyze Cams all V3. Unable to use with Alexa. All firmwares are current as of 12/2021. I have tried two methods to integrate with Alexa and failed:

  1. First attempt: I Activated Alexa within Wyze app under “smart integrations” in account menu. States it was successful and Alexa app shows the “Wyze” skill as being active. However, when I try to discover devices it will not detect any of the cameras. I only have one wifi account at home and cameras all work in Wyze app

2)second attept: Turned off Smart Integrations in Wyze. Then tried to activate the “wyze” skill in Alexa. Takes me to a Wyze login site. I enter user name and password, then when I enter, nothing happens. It will never login. No error, or anything. Just stays stuck on login screen. I verified user name and password multiple times by logging in and out of Wyze app.

Any suggestions?

Welcome to the forum @Bowman123.

Do you have 2 Factor Authentication turned on for your Wyze account? I believe 2FA needs to be off in order to connect the Wyze Skill to Alexa

I have 2FA without an issue on Alexa. I would remove the skill all together from Alexa and then restart after clearing the cache from Wyze and then logging out of the Wyze App and then Logging back in.

Make sure you know the password, if you have the incorrect password, it wont do anything either.

1 Like

I did have it on but have turned it off before posting this thread. I have tried logging in and out of Wyze and Alexa apps.

I will try clearing cache. Did you link account via Alexa app skills or the Wyze App?

@spamoni4 I think it has to be off to initially connect then can be turned back on… I think :wink:

@Bowman123 I setup my association up through Alexa adding the Wyze Skill

1 Like

The Wyze Cameras didn’t show up in my Alexa until I signed up for Cam Plus. The benefit was, it gave me Person Detection when I used the Wyze Cam for a trigger. May not be worth it to you.

While we are on the subject, the main Wyze cam that I wanted to display to either of my Show 8’s would not come up even with Person Detection enabled. Then I tried other V3’s. They worked. Even with current FW, my “main” V3 still would not display on either Show 8. So, I did what any shady tree mech would do, I traded out my “main” for one that I never care for the Show 8 to display. Problem solved, but didn’t get to the underlying reason it would not.