Added wyze camera, wifi keeps failing

Hi there, just picked up the wyze cam. As soon as I successfully set it up, our wifi router fails and I have to reset the router. I can’t find other people with similar issues. Speed test is 18 down 12 up. There are 4 phones connected to wifi. Any idea what root cause could be?

Yea, I’d say something is VERY wrong … you should NEVER have to reset the network after adding a device.

Remove the camera from the network (just turn it off, ie unplug it) and see how your network runs afterwards…

Thanks for reply. Removed cam, everything functioning fine.

Have not heard anything similar. I would refresh firmware on the camera, and if behavior continues, get hold of tech support.

I have never had any device crash my router. I have exceeded maximum wifi clients on a band, causing the router to refuse new connections. I have 40+ devices over 3 bands, and router is stable. However, be cautious of running logs or unnecessary processes on any router that is being pushed towards its limits.

What router/firmware are you running, and have you updated its firmware?

How many devices are attaching to the Wifi, broken down by band?

Remember to include all IOT devices. Easy way is to check attached devices section in router

1 Like

Thank you for reply. It is an older linksys router (wrt-54g), only supporting 2.4g. There are 4 phones on network + 1 laptop + 1 nest thermostat + 1 Alexa dot

That’s WAY overkill troubleshooting… you REALLY think the average citizen knows about Wifi bands??

  • “everything runs fine before install” …
  • install new device …
  • now things don’t work or have negatively influenced the network…

It’s obvious where the issue is : )

I think based on that router alone you may have to upgrade, being that its almost 18 years old.

Thanks for reply. We had a Logitech security cam previously connected and working fine. Tried to upgrade to Wyze and issues started

Even if its older, your not pushing the envelope on connected devices. How is the stability if you are facetiming or video calling on a phone? I would recommend upgrading your router to at least a dual band, simply because netgear will not be patching such an old beastie and security is jeapordized on old firmware.

However, simply attaching a Wyze Cam to your wifi should not be crashing anything. I would reflash current firmware to the cam and retest.

Just so I am clear, exactly what is the behavior? How are you verifying the state of the router?

Everything functioning fine pre cam install

Install cam, see video fine. Then all devices disconnect from wifi and connection is not available

Unplugged Wyze cam, and everything functions fine again

Disagree, that beastie with a clean config can handle 6 concurrent connections. It will load dd-wrt which is a solid build. But hey, push him to buy a new router before checking out the state of affairs

I would contact tech support and have them give this a once over. If your problems go away by unplugging the cam, and you have successfully pushed another webcam, I dont think it’s your router, however, no security patches is going to be an ongoing issue, so I would upgrade when you can.

I had the same idea as you, just didn’t type it out in as many words. Looks like that product last had a firmware update in 2012. Edit: I agree that that product should be able to handle the items the users said would, but seeing your troubleshooting conversation it appeared to me as if the weak leak was the router. I am still scrubbing the forums and google to see if I can find a same or similar situation. /edit

@Willsand, Here is the link to create a support ticket if you would like them to take a look and see if they have any insight.

Thank you both very much for your help. Glad to know I’m not totally crazy! I’ve created a support ticket and will follow up here if I’m able to successfully troubleshoot. Thanks again


What are the stats on this person’s network BEFORE adding the Wyze cam are you basing your opinion on?

Everything worked before

Most versions of the WRT54G are solid workhorses, especially with DD-WRT or Tomato, and should definitely handle that much traffic.

But, yeah, lack of 5Ghz and recent security updates make them better as fond memories. :pensive:

Maybe he got one of the Omegle firmware special editions… :stuck_out_tongue:

1 Like

Are you using DHCP or assigning static IP addresses?

Hi - using DHCP

Do you know if your router has persistent DHCP, meaning that each time a device attaches to the network, it will be served the same IP?

I have an unrelated issue with Wyze Sense product, and it appears that my change from router served DHCP to RaspberryPi running PiHole serving DHCP may have been a contributing factor.

I have not seen need for static IP on the cams, bulbs, or WiFi protocol devices, but it may be a factor in the case of your router if the crash occurs immediately after negotiating connection, the DHCP table may be corrupted, or at least that the device is not served IP/DNS data or a corrupt set.

If you can, please log in to the router, open your browser, the default address for that model should be
Username: admin Password: password
These assume you did not update them, obviously use the updated info if you have. In the settings menu under LAN will be DHCP settings and DNS settings. I would update your DNS1 to and DNS2 to the

Next check the attached devices table. It’s been a minute since I looked at that firmware, but it will say either attached devices, or device manager and will list the devices attached by either LAN or WiFi, their assigned IP. and their MAC address (hardware ID).
Make sure you see an entry for the Wyze cam, since it’s the last device you added, it should be at the bottom of the list. The MAC address should start with “2C:AA:8E:” followed by 6 more Hex digits.

If you do not see it, then it would appear that the crash is interrupting the DHCP handshake. If it is there, verify that there is only one record, but I would remove it regardless. Should be a radio button next to the devices that will allow you to delete them.

As a further thought, since you have indicated only 6 devices are actively joining your WiFi. I would take the opportunity to clean out the device list. This will allow a fresh IP to be assigned to your current devices, and take care of the old data. Your devices will not be immediately dropped, they will refresh their IP at either the next time they join the WiFi, or at the end of their current lease.

After logging off the router, reboot the router, then either reboot your devices or disconnect and reconnect to your WiFi.

Verify that all devices are then recorded in your device table (login to the router again).

Now, reconnect your Wyze Cam to the Wyze App. This will cause the Cam to be issued a fresh IP/DNS server list.

If your router fails/locks up again, please pay particular attention to exactly when in the “adding new device” process your router locks up, or exactly what you did in the App (viewing camera in main menu, after clicking Camera to get a close up, etc.

Pay particular attention to the connection steps when you click on the Cam in the app which are a three step process detailed by a wait circle in the center of the Cam display.

Lastly, recheck the device table on the router to see if the new updated record is present for the Wyze Cam and make sure that only one record exists. There was a persistent issue of duplicate or corrupt DHCP records mentioned in Netgears knowledge base.

Sorry if this is long winded, please advise if anything is unclear. Please advise your results.