Accessing Wyze Cam via Windows Environment through Bluestacks

It seem that many have asked if you could access the wyze cam via a window host. I was able to by installing an Android Emulator on my Laptop and PC.

This emulator that will allow you run most of the apps locate on the android store on your windows host while still be able access your local. This does not require a dual boot configuration. Just install and configure.

This process does seem to be support by the vendor but works and allow me to access the cameras the same as with my smart phone.

Hope this help if not raise a thought of intervention. I have reference some site that explain more of the setup to BlueStacks.

How to Install BlueStacks on Windows 10, 8.1, 8 & 7

Let me know if this has been helpful…

Sharing is the key to more knowledge.

If you keep it to yourself no one will know you know…



Thank you, I think that’s an excellent idea.

I’m thinking with this emulator, one could set up an off-site recording of their cameras. I think I’ll give that a try.

Great idea! Why didn’t I think of this? Hmm Store videos off on the NAS etc…

I tried this and it works very well. Thank you, One question I have is if you take a snapshot of a camera feed, where does it store the photo?

It should default the local device or what ever device you chose.

It will by in the “Wyze” album of your phone’s photo app.

1 Like

Would anyone be nervous about privacy and security, as in hacking into BlueStacks and gaining access to your camera feeds?

It’s just as secured as what you have from your phone. You’re not doing anything to the Wyze cameras or to your account. You simply access them from an Android emulator in your PC

1 Like

Installed Bluestacks and then the Wyze app on top of it
It runs but can never get video.
It seems to connect to the cameras - but gets stuck

  • sometimes it gets stuck at “Getting video data 1/2/3”
  • other times it issues an error: Connection failed (error code :20)
  • other times it gives up and says “Connection failed” Please try:1.Force close app and retry 2. Power cycle the camera.

Meanwhile the app works fine on my phone (Android)

I’m on windows 10,

Any suggestions?

Unfortunately this only works if you own an Android device. I do not. I am seeking a way to watch cams on my windows laptop. I only own Apple devices. Is there a work around for that?

You do not have to own an Android device to use Bluestacks. You will, however, need a Google account:

I have the same problem, but one of my cameras works fine the other does not display (same errors as above).
What I have discovered is that the camera that works has not been updated to the latest firmware update.
(image )
The one that fails has been updated twice.


I changed the Engine settings in BlueStacks and now I can see both cameras.

Graphics engine: set to Compatibility
Graphics renderer: set to OpenGL
GPU settings: set to Prefer dedicated
ABI setting: set to ARM64


Made an account to say thanks :slight_smile: This fixed it for me too

I also facing the same issue for a week ago. then I have seen an article on blue stack. Now my solution is fixed. check

I had the same problem with wzye on bluestacks 4 with hyper V. I could only see the recorded stuff. Once I enabled hardware decoding in the wyze account settings I was able to see the live stream. To do that in the Wyze app tap the Account button > App Settings > Enabled Hardware Decoder


I tried this today but it didn’t work. Installed bluestacks on Windows 10 okay. Installed the Wyze app in bluestacks okay. Started the add device thing, scanned the QR code okay. Then I get a voice error from the Wyze camera “cannot find specific network name”. But neither bluestacks nor the Wyze app asked me for a network name.

Added a v3 to my network. Shows up on phone app but NOT on Bluestacks version. Any solutions?

You don’t need to re-scan the cameras in BlueStacks. You just install the Wyze app and login with your Wyze account that you used on your phone.

All the camera settings are in the cloud.

i forgot to update my bluestacks 5 wyze app to the required update recently released. i have the latest update and firmware on my cell. it works fine on that. is there any way i can stiil update my bluestacks wyze app? cause its not connecting now without on bluestacks 5.