AC running but no air at vent

Hi there,

I just wired up my thermostat and am trying to figure out why I am not getting any A/C in the house.

Strangely, I can see and hear that the A/C units fan is running however there is no air coming out of the vent. No air at all as if the system is off.

I can turn on the heat and do feel hot air coming through. I can also hear the furnace’s gas kick on when powered on.

I have a newer (2021) Carrier gas furnace with pump backup and and old A/C unit. I followed the instructions in the app to a T and connected the C wire at the furnace panel.

I switched everything back to normal and it worked perfectly normal so I’m hoping the wiring is the issue.

Here are the photos of the thermostat panel pre install (marked with where the app indicated they should be plugged in on the Wyze therm.) Along with the furnace panel pre install of c wire adapter

Pre install the colors of the wire coincided with the R, W, G, and Y ports if that helps.

Greatly appreciate any help!

[Uploading: 8D8B910B-D629-483A-99A2-E462C4235855.jpeg…]

Try fishing around in your wall a bit and see if you find a Blue wire… You might not need the C adapter.


Yep, There was a blue wire in the wall and connected it to the C. Hopefully that’s it!

Looks like I blew the low voltage fuse on the furnace playing around so I’ll have to go without A/C for the night unless I can find a 3A to continue testing.

if you’ve got the blue wire attached to C on both ends, you don’t need the C adapter, so make sure to tell the app that you have a c wire during setup. The fuse is a standard automotive blade style fuse, so you might have a spare in your car.


You read my mind. I immediately started digging through our cars fuse boxes and couldn’t find anything close to a 3 amp standard sized blade fuse. Only mini. All the standard fuses were 20 amp and up.

Will start this project back up bright and early with a trip to Harbor Freight for some fuses.

Replaced the fuse and connected the blue C wire on both ends still no luck. The Wyze thermostat clicks every couple seconds but no power on the screen.

I connected the old thermostat (without the c wire) and it’s running fine.

Any ideas what else I could try?

Did you reset the wyze thermostat, telling it you have a C wire?

With the blue c wire connected on both ends I can’t get the thermostat to power on at all. It just clicks repeatedly.

Hmm. The blue wire must not be connected in the middle somewhere then. Is your furnace located inside or outside your house?
I have a feeling that your Y and G wires might be interrupted somewhere along the line to go to the outdoor unit if your furnace is located inside the house.
Normally, I’d expect to see the Y wire go from the thermostat to the furnace and then to the outdoor a/c compressor, but sometimes hvac contractors take a shortcut and splice the compressor inline with the Y wire, which interrupts it and prevents the wyze’s C adapter from working properly. If you can find the point at which they put that splice in and hook the blue wire coming from the thermostat side of the wire to the blue wire coming from the furnace, you should get it to work.

There should be a different wire spliced to the blue wire coming from the furnace at that point, they can all be connected together. Connecting the blue wire in this way will result in you not needing the C adapter.

By the way, to prevent shorts and blowing the fuse again, you can remove that bit of packing tape that’s holding the safety interlock switch closed on your furnace and it will disconnect power to the furnace board as long as the front panel is off of the furnace, like it came from the factory.


Ah, took another look and I’m seeing this electric taped bulk of wire and wire nuts coming out of the furnace. I’m guessing this might be where the shortcut you mentioned may be.

Will get everything unwrapped and see what I can find.

10/4 on packaging tape not the wisest on my part.

1 Like

Here’s what I’m seeing inside that electric tape. Looks like Yellow is indeed taped into blue.

Blue on furnace running to an older yellow wire which is going to the AC unit.

Yellow (y) coming out of the furnace is not connected to anything

1 Like

Alright some progress. I found an old wire coming from the thermostat that was disconnected and spliced into the blue cable nut. I can now power on the thermostat without the C adapter!

I’m now seeing the same behavior I was seeing with the c adapter. Ac unit kicking on but no air coming out the vents.

Wondering if the unconnected yellow wire coming out of the furnace may need to be spliced in somewhere.

1 Like

Actually it looks like we’re good to go! I factory reset the thermostat after my last post and set the new wiring.

Thereafter it took my unit a few minutes to kick on after restoring power. The A/C is blowing cool as it ever did.

I’ll check the heat tomorrow.

Thank you so much, Speadie! You saved me who knows how much on having an HVAC tech come out. I really appreciate you.

Just curious, do you do HVAC for a living?


Building maintenance, which tends to include a fair bit of HVACR.
I do moonlight as a HVAC tech for a couple of local companies as well.