2 Video Doorbell Pro's that Refuse to Upload Event Video. Livestream Works Fine

So this is very perplexing to me and NUMEROUS extensive phone and email conversations with support have been pretty awful. Here’s what’s going on:

My mom installed 2 video doorbell pros at her house, which has Frontier internet. Setup went smoothly and connection to the Chimes was good despite their relatively slow internet speed. Never once since install a couple months ago has an event video been uploaded.
Live stream works perfectly via the app in both android and iphone and you can see everything clearly.

Detection settings seem to be good as well, as the events DO trigger for people, pets, packages, and also for when the button is pressed. I was continuously asked to look at detection settings but it’s clearly not that since the events trigger, it just never has a video attached.

The internet speed was slow, about 12Mb down and 6Mb up (she lives in the boonies), and we thought it was just too slow of an upload speed for it to get the event video uploaded in time so she upgraded her home internet. Current speed tests show 79Mb down and 11.2Mb up. Issues still happen and nothing seemed to change except for livestream video quality is a little clearer now.

The actual wifi itself was a concern because she was just using the Frontier-provided router and some repeaters. I connected a Google WiFi mesh system and reconfigured both doorbells to use the mesh wifi with great coverage and still no difference.

Support also asked that i switch to WiFi channel 6, which I couldn’t do on the mesh but I re-configured them again to go back to Frontier and tried 6 and no change.

Firmware is up to date and I don’t think it’s a glitch with the device itself since BOTH doorbells have done this since day 1 and never once has an event video been uploaded.

Now for the actual app experience. Notification triggers successfully. If you click on the notification, you get a popup that says “Failed to upload” and that it could be because of network issues and that i should submit a log. I’ve done that numerous times but no response. Screenshot of this page attached.
If you go into the camera view itself you can see the events and the trigger-type/time/date details just like a normal camera, but when clicking them, nothing loads and you just have a black screen and they play/pause/download/mute buttons are greyed out (so clearly video never uploaded so it can’t be retrieved).
Again, going to the livestream works fine and is responsive. I can have live conversations with my mom through that camera with barely any delay so I know it’s a good connection. Also interesting, the bitrate it shows in the top left is usually around 115kb/s to 120kb/s and that’s the same speed as my functional video-doorbell-pro that does work correctly (albeit in a different house in a different state). This makes me think that it’s not actually a speed issue either. Standing at the same outdoor location, I’m able to upload things via my cell phone just fine.

My belief in what the actual issue is would be something maybe network related on the router itself. Maybe the ports that Wyze uses to upload the videos are blocked or routed elsewhere for some reason. If anyone knows the ports that are used or any additional router settings I can review for her router that would be super helpful. It seems to fail INSTANTLY which makes me think the connection to upload isn’t ever established, and also must be a different port than is used for livestream viewing.

If anyone has any other ideas, I’m happy to entertain them. I’m a software dev with a little bit of networking knowledge but not much so this is a little out of my element, but I feel like I’ve isolated the problem from being hardware (camera) or app settings, and I believe it’s network/router related (but not speed). Help!!

(apparently I can only attach 1 screenshot, so just sending the first error. I’ll see if i can reply with the others.)

Here’s the view if you click on the event from the camera page itself. Buttons greyed out.

1 Like

There have been issues lately (like last week) with other cams failing to upload events pretty often. For me, power cycling the device usually fixes it. Not sure if this applies to the doorbell, but try flipping the breaker or removing it from the wall for a minute. If that doesn’t work, try deleting them and setting them back up. Sorry your having issues with the devices!

Thanks for your reply. Unfortunately that hasnt helped. The same issue has been happening for a couple months and has never once worked since install. Power cycled, tried with the cam sitting inside physically next to the router, deleted the cam and reconfiguring 4-5 times. Nothing seems to change it, which makes me think it’s a networking issue.

Sorry if you already said this, but have you tried moving one of the doorbells to your house and setting it up there? That will determine if it’s the cam or the network, though it’s sounding like the network.

I haven’t, but I’m 12 hours away so that wouldn’t be an ideal test to perform, haha.